Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Wordwrap in syntaxmemo


#1

I can’t find a wordwrap option when logging source code.
I have some nasty long XML files, and I have a feeling that
not only it’s not word wrapped, but some characters are missing from the line (component cant’s display it maybe?)

{ comment:
Also maybe you could consider embedding ECSyntaxMemo instead.
Check : http://www.econtrol.ru/syntedit_e.html
I have been using it for a while, it has folding, and support for like 25-30 languages by default. And it’s pretty
cheap.
}

Have a nice day,
Attila


#2

Hello Attila,

the Source Viewer doesn’t have a word wrap option currently. I added it to the feature list.

Are you using Unicode in your XML files? If so, then this is probably the reason for the missing characters because the Source Viewer doesn’t support Unicode currently. Support for Unicode is very high on our list of features.

Thanks for the component link. It looks like a good alternative.


#3

That syntaxmemo component is fully unicode enabled and supports wordwrap.


#4

We will look into it, as it seems like a very good component (and the Unicode support is a big plus).