Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Where are imbedded images stored?


#1

Hi,

Today we started having issues with a group of our UAT folks and other staff. A bunch of us can not see imbedded images in TR (4.0.2.3269) with our own local installation with IE11, newest Firefox and Chrome. It is no all cases however…

When I go the cases in Test Suites and Cases a lot of us get the broken link icon. If we click in it it just churns with an icon. In one cases 1 imbedded image is seen but the others are broken.

How are the imbedded images stored and if they are converted to files - where are those files stored?

EDIT: Found them in the Attachments table. I see there is a reference to Case_id and Project_id. The problem seemed to center around cases that were copied to another project. We eventually got them back - even though I did it I am not sure how we fixed it. Will find out the details and post them.

EDIT 2: From the Dashboard:

  1. Select BKS-QA (original test suite)
  2. Click on the tab ‘Test Suites & Cases’
  3. Select BKS
  4. Open a case with an Image (Add Note has an image)
  5. Select Edit
  6. Don’t change anything, Cancel

Now go to back to your Dashboard and select BKS-UAT (this is a copy of the BKS - QA suite) and go to Test Runs & Results and open your test run. You should now be able to see your images.

The users who originally opened/viewed the original test cases in the BKS - QA suite - could see the images in the copied suite. It was users who did not view any of the cases in the original suite, that could not see the images in the copied suite (BKS - UAT).


#2

Hello Brian,

Thanks for your posting. This is permission related and indicates that you/your users don’t have access to the original project the test cases were copied from. It’s planned to look into this from our side and only happens with embedded screenshots (not regular attachments) and we already have this on our todo list. This is somewhat of an edge case but might not be expected and it’s planned to look into this for a future version.

You can make the screenshots visible either by giving your users access to the original project, or by uploading the images again to the new project.

Regards,
Tobias


#3

Thanks for the information - I gave the rest of our team the information.


#4

You are welcome, Brian!

Regards,
Tobias


#5

Hi,

When will this issue be solved? The workarounds are not practical in the long run.

Regards,
Andreas


#6

Hello Andreas,

Thanks for your feedback. It’s planned to look into this for one of the next versions again.

Regards,
Tobias


#7

I have this problem, and definitely have (admin) access to both projects. I can see the images in the suite, but not the test run. The work around above does not work for me (although I can’t understand how it would work!). We have recently upgraded to 5.2.1


#8

Hi Ellie,

Thanks for your feedback. Can you please send a screenshots of the projects/suites/run to our help desk at contact@gurock.com? You would also need read access to the projects and this is independent of the admin status:

http://docs.gurock.com/testrail-userguide/howto-permissions

Cheers,
Tobias