Subscribe Join 180,000+ subscribers and receive articles from our blog about software quality, testing, QA and security. Subscribe

We cannot update to version 6.3.1.1004

We were on version 6.2.2.1107 and ran the update script:

/appz/docker/service/testrail# ./upgradeTestRail.sh

###########################################################################################
TestRail quick upgrade
This script will help you to upgrade TestRail.
It currently only works with the ‘standard docker-compose.yml’ file , which uses Apache.
!! Important: If you’re running nginx, you need to do the update manually for now.

Please be aware that you will need ‘sudo’ installed to run this script.
###################################################################################

Press ‘Enter’ to continue (or Ctrl+C to abort)

Upgrading TestRail
– assuming the DB is in _mysql and the reports/attachments/… files in _opt

These TestRail versions are available
latest
6.0
6.0.0
6.0.0.4140
6.0.1
6.0.1.4163
6.1
6.1.0
6.1.0.4369
6.1.1
6.1.1.1021
6.2
6.2.3
6.2.3.1114
6.3
6.3.1
6.3.1.1004

Press ‘l’ to continue with ‘latest’ or type in the version you want to use: l


After the update it says in the GUI at ‘Administration’:

TestRail version 6.3.0.1120 (update available)

The same (unexpected) version is stated at ‘Help’ > ‘About TestRail’.


As you may have noticed this version wasn’t even an option at the update script - and we used “l” for latest.
We re-ran the update script specifically specifying version 6.3.1.1004, but no newer version was installed.


What can we do now?