Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Upgrade from version 4.0.2.3269 to 5.0.2.3372


#1

Just upgraded from Testrail version 4.0.2.3269 to Testrail version 5.0.2.3372 and getting the following error in the System Log.

Is there a known fix for this issue ?

[ControllerException] Your installation was updated to TestRail 5.0.2.3372 but this page still runs the previous version. Please refresh this page.

Details:
File: /var/www/cyan/sys/helpers/ex.php
Line: 25
Status Code: 500
Host: testrail
Uri: /cyan/index.php?/tests/ajax_reload_timer (POST)

Browser: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36
PHP: 5.5.9-1ubuntu4.5
Server: Linux 3.13.0-39-generic #66-Ubuntu SMP Tue Oct 28 13:30:27 UTC 2014 x86_64

test_id: 532051
_token: b704cc98dfbd8b5899e393836c627378
_version: 4.0.2.3269

Trace:
at ex::raise (ex.php:43)
at ex::raisev (controller.php:380)
at Controller->_raiset (application.php:208)
at ApplicationController->_check_for_client_version (application.php:21)
at ApplicationController->_init (protected.php:16)
at ProtectedController->_init (tests.php:15)
at Tests_controller->_init (gizmo.php:106)
at require_once (index.php:106)


#2

Hi John,

Thanks for your posting. This means that one of your users still has a TestRail page open that was served with the previous TestRail version. TestRail would detect the different client/server version numbers and adds this message to the log. You can simply ignore this message and the user would only need to refresh his browser page.

Cheers,
Tobias