Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Undefined Offset: 5


#1

Hello
I’m using TestRail v5.5.1.3746 + MantisBT 1.2.15
Connecting using Mantis Defect Plugin.
I’m seeing my Mantis Projects in the DropDown Menu.
But when I try to Push I get the following error message:
**Plugin “Mantis” returned an error: Error Type: **
SYSTEM NOTICE, Error Description: Undefined offset: 5
Any suggestions ?
Thanks in advance


#2

HELP GUYS…
Any takers…


#3

I installed the latest version of Mantis 2.18.0 and I have the same error…
HELP…


#4

This seems to me to be an issue with Mantis more than Test Rail. I did a Google search and found this thread:

https://www.mantisbt.org/forums/viewtopic.php?f=4&t=21339&sid=ffb639985cbec5262ff4c4d445bddb8e&start=15

Look at the user AlexeiK especially on the second page where it looks like there might be an issue with the MSSQL driver (post 4 and 6 on page 2) and maybe the issue is the same as yours or similar enough to get what you need…


#5

Hi BGanger
Thanks for your answer, the problem seems the same but it’s applicable on the an old version.
Even so I tried it and it’s the same.
I’ll try to post the problem on Mantis Forum and see if there is any idea / luck.
Thanks again.


#6

Hello again
Just to help anybody else with the same problem, here’s my finidng:
I installed TestRail v5.5.1.3746 and tried to use it with my MantisBT 1.2.15 version.
When I try to push I receive the error message.
So I installed MantisBT new version 2.8.0 and keeping the old SQL database, the new MantisBT version worked with the old DB, I didn’t test it Intensely, just from the outside.
When I tried to push from TestRail I had the same error message…
The I created a new DB for the New MantisBT version… and tried to push… TA DA… it’s working as it should pushing to MantisBT and getting back an ID.
Moral of the story… Old with old, New with new… = 3 days of work + fistfull of hair…