Join 34,000+ subscribers and receive articles from our
blog about software quality, testing, QA and security.

Unable to integrate with JIRA


I’m also experiencing this issue. I double checked with the Jira admin and we have the Jira user and the testrail settings. We also have the Jira TestRail plugin fullly working, we just can’t push issues to Jira at the moment.

I’ve configured test rail to point to Jira, it looks like it is able to pull the projects, however it’s not able to select several of our actual engineering projects. (it is able to push to our help desk tickets)

Plugin “Jira_REST” returned an error: Invalid user or password or insufficient permissions for the integration user (HTTP code 401). Please make sure to use your actual JIRA username for the integration (not your email address, for example).


Hi David,

Thanks for your posting. This usually means that your username doesn’t have the required permissions to add a new issue in JIRA (to the selected project). Could you/your JIRA administrator review this? It seems that the username and password is correct (otherwise you wouldn’t see the projects as you mentioned) and this seems to be a permission issue with the JIRA user.



Hello - Our Jira integration seems to be working, except there is only one issue: when we are displaying a test case, and under “References” there is a link to a Jira ticket, if we click on that link, the Jira ticket is displayed correctly, but if we do not click on the link, but just hover over the link, we get the popup error “Jira_REST” returned an error: couldn’t connect to host".


Hi Michael,

This is a configuration issue with the integration on Administration > Integration. It’s likely that you have configured an incorrect address either for the Defect Plugin (Defects tab) or Reference Plugin (References tab) configuration. Can you review this please? We are also happy to help if you could send a screenshot to of this page (both tabs and with possible passwords removed, please).



Also having the same issue right now.
Plugin “Jira_REST” returned an error: Invalid user or password or insufficient permissions for the integration user (HTTP code 401). Please make sure to use your actual JIRA username for the integration (not your email address, for example).
It used to work but suddenly stopped, no changes on my side (except that I cleared all my cookes) I have confirmed access to Jira and able to do anything I need so something is going on inside the tool. Please advise me…

Vlad Antonov


Hi Vlad,

Thanks for your posting. Please make sure that the JIRA username and password you configured in TestRail still match your JIRA username/password. 401 is a permissions/authentication issue and you can update these values in TestRail on the My Settings page.



Hi guys

I have the same issue of the plug-in Jira_Rest returned an error when I mouse over a defect (that I have access to directly in Jira). Cf screenshot

I used the user variable in TestRail in the Integration settings and also put my user and password directly in the defect plugin pannel.
I also checked Jira if Accept Remote API calls was on and it is set up to on
I used a different TestRail account (not my jira account right now)
I have access to the jira project

Any tip?



403 sounds like a permission error. Can you please check if your JIRA user has access to the project and/or issue in JIRA?



Hi Tobias

I have an admin jira account. I checked the issue I tried to link in the test result and could open it.


Can I write directly in the defect plug-in window my password that contains a % character?
I already tried without any quote like it is described in your documents and I got the same error.


Thanks for your reply. We recommend using the variables instead and you can also use the fallback configuration if you don’t want to configure the JIRA user for each TestRail user:

The Configure JIRA Integration button on Administration > Integration takes care of setting everything up.



I tried both (User variable and without) and it is still not working.
Could it be a unauthorized port issue?


Hi Gast,

TestRail is actually able to reach JIRA but JIRA returns a permission (or maybe authentication) issue. Can you please check if you haven’t overridden the integration settings for the project? You would see a yellow warning/info message at the top of the Administration > Integration page in this case and you can clear the project settings and only use the global settings.



I only defined the global settings under Administration > Integration.
The project defect settings are left empty.


We installed a trial version which is outside of our company’s network.
And this network blocks the access from outside.


TestRail is actually able to reach JIRA, otherwise you would see a different error message and not a 403. Do you still see the 403 or something else? If your JIRA username and password you use for the integration are correct, please check if they contain any special characters outside the regular ASCII/English alphabet as international/Unicode characters wouldn’t be supported by JIRA’s API and authentication.



Weird then
I changed my password as I thought the % in it might be an issue but the same error still occurs.


Do you still see the 403 or something else? Do you use your JIRA username or email address for the integration (email address wouldn’t be supported with the API)?



Hi Tobias

I updated the password in the fallback field of the user variable but it is still happening and I’m using my JIRA username…I don’t get it.



Hi Stéphanie,

Have you overridden the username/password on your My Settings page? This would be given precedence over the fallback values (which are only used in case your settings on My Settings are empty).