Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Unable to integrate with JIRA


#33

Hi Gast,

TestRail is actually able to reach JIRA but JIRA returns a permission (or maybe authentication) issue. Can you please check if you haven’t overridden the integration settings for the project? You would see a yellow warning/info message at the top of the Administration > Integration page in this case and you can clear the project settings and only use the global settings.

Cheers,
Tobias


#34

I only defined the global settings under Administration > Integration.
The project defect settings are left empty.


#35

We installed a trial version which is outside of our company’s network.
And this network blocks the access from outside.


#36

TestRail is actually able to reach JIRA, otherwise you would see a different error message and not a 403. Do you still see the 403 or something else? If your JIRA username and password you use for the integration are correct, please check if they contain any special characters outside the regular ASCII/English alphabet as international/Unicode characters wouldn’t be supported by JIRA’s API and authentication.

Cheers,
Tobias


#37

Weird then
I changed my password as I thought the % in it might be an issue but the same error still occurs.


#38

Do you still see the 403 or something else? Do you use your JIRA username or email address for the integration (email address wouldn’t be supported with the API)?

Cheers,
Tobias


#39

Hi Tobias

I updated the password in the fallback field of the user variable but it is still happening and I’m using my JIRA username…I don’t get it.

Stéphanie


#40

Hi Stéphanie,

Have you overridden the username/password on your My Settings page? This would be given precedence over the fallback values (which are only used in case your settings on My Settings are empty).

Cheers,
Tobias


#41

Yes, with my JIRA account in both and I got the same error 403


#42

Is there a way of getting some logs? to have more details on the error


#43

Hi Stéphanie,

Yes, there are logs and you would need to enable debug logging in this case. Are you on TestRail Server or TestRail Cloud? For TestRail Server, you can enable debug logging as follows:

http://docs.gurock.com/testrail-faq/system-debug

We can enable logging for TestRail Cloud instance if you send a quick email with your TestRail address to contact@gurock.com. In either case, we are happy to review the logs (just send them via email if you use TestRail Server).

Cheers,
Tobias


#45

Hi Tobias,
I hope you’re still around as you seemed to have helped plenty of users above with their JIRA/Testrail integration issues and am hoping you can help with mine.

I’m getting the following error message when I do a mouse-hover over a defect link:
“Plugin “Jira_REST” returned an error: Invalid HTTP code (404). Please verify the address of your JIRA installation in the configuration settings and that TestRail can reach your JIRA server.”

I don’t have TestRail admin access (yet), but am working with an admin locally. He has confirmed the address of our JIRA installation in the configuration settings and that TestRail can indeed reach our JIRA Server.

I’d be more than happy to supply debug logs (confirmed deploy_debug is set to ‘true’) in config.php, however, have not been able to locate these logs unless they are the daily logs found under /opt/testrail/logs/ directory.

I have more data points to share but would like to get your input first on best place to start given the above error.

Thank you!


Error received when viewing defect through Test Rail
#46

Update:
Just a heads-up, I was able to resolve the issue internally. It was a proxy/networking issue preventing authentication packets from getting through and thus the HTTP Error Code 404, which after troubleshooting turned into 401 and now after resolving the exact jira_REST URL, all is good.


#47

Hi there,

Thank you for the update. Glad to hear that you were able to get this resolved and thank you for posting your solution.


#48

error
Can anyone please help me about this…


#49

Have you tried any of the things mentioned in this thread and if so - what did you try what were the results? There are at least 2 things to look at for the 404 error in this thread.


#50

Hi,
Tried all the steps below expect the first one. Not sure where I can find this option.

  1. JIRA Admin/System - Accept remote API calls = on Not Checked

  2. JIRA username (not email) and password are entered correctly for the TestRail user. Checked

  3. Defect plugin set to Jira_REST. Checked

  4. The user variables are set to ‘jira_user’ and ‘jira_password’ Checked

  5. Fallback matches a JIRA user with correct access permissions (administrator just to be sure) ** Where can I find it? **

  6. The Plugin looks correct with Checked

[connection]
address=https://xxxxx.atlassian.net/
user=%jira_user%
password=%jira_password%

Reference URL is not working for me. I have entered the reference url as “https://qmacbis.atlassian.net/browse/%id%” but still I see an issue when i click on the Reference url link in Test cases.
Following is the error message i received -

Plugin “Jira_REST” returned an error: Invalid HTTP code (404). Please verify the address of your JIRA installation in the configuration settings and that TestRail can reach your JIRA server.


#51

I am having similar issue as below
Getting below error on Jira link under references in Test rail test cases
"Plugin Jira_REST" returned an error: Invalid user or password or insufficient permissions for the integration user (HTTP code 403). Please make sure to use your actual JIRA username for the integration (not your email address, for example)…"

I checked the username and password is same as JIRA in testrail mysettings -> settings
I have admin access too,Not sure what permission is required


#52

Hi Tobias

The 403 error mentionned before is back (Messages posted in that thread on October 2016) and we have not changed anything on our side.

Anything new on testrail servers?

Thnaks for your reply

Stéphanie


#53

Hi,
We have an incomprehensible problem with the integration of Jira.

Configuration of the plug-in and the administrative part was successful. In the Fat appeared tab TestRail, But it is empty. The TCs in which the reference is indicated also are not displayed in the tasks. But when viewing the defect in the TR, the task of the jira is displayed, which I linked.

in console is displayed “Refused to display” https://{server}.com//index.php?/ext/jira/render_panel&jv=7.1.8&ae=sdk&av=1&issue={project}-405&panel=results&login=button&frame=tr-frame-panel-results