Join 34,000+ subscribers and receive articles from our
blog about software quality, testing, QA and security.

Unable to install TestRail on JIRA Cloud. 401 received



When I press on Install button I have the following message:

The add-on host returned HTTP response code 401 when we tried to contact it during installation. Please try again later or contact the add-on vendor.

I have tried it on different hours.
I am on a JIRA cloud instance. Any idea ?

Thank you


Try this:


Thanks but I did not be asked to enter any username.
I got the error message when trying to install TestRail



From looking at some documents - it seems you are trying to use the Add On for Test Rail and it looks like JIRA expects that Test Rail has already been installed locally.

So he next question is if Test Rail is actually installed yet? My guess is that JIRA is looking for a Test Rial install and not finding it.


Thank you BGanger

I already have done those steps, but when I try to ‘Activate the add-on’ I received the message error, so the Add-on is never installed.
Does 401 error code mean there is an instance already installed? Maybe I can ask Atlassian to clean it…



A HTTP 401 is an unauthorized error - not sure if it is being thrown from the JIRA side or Test Rail side. I still wonder if the Integration settings on the Test Rail instance is not quite right and going back to read the full thread I posted before might be needed.



thanks for your time

We have tried with other 2 users with same result.
We log into jira using our google account (SAML) and we always have to pass through google to enter into jira maybe it is related with that ?