Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Trac error when trying to 'push'


#1

I’m testing TestRail, and trying to integrate it with our existing Trac installation.
I’ve set up the plugin with what I believe are the right details, but I’m getting a ‘404’ error when I push the ‘Push’ link on test results.
I’ve checked the request, and its failing in the initial sending of the ‘system.getAPIVersion’ command.

The ‘Add’ link works, but obviously that works on a separate URL.

The system log has logged this:

[code][ERROR] 2011-06-13 18:46:06 [268ms]: [TracException] Invalid HTTP code (404)

Details:
File: C:\Users\clocke\Documents\Downloads\Applications\XAMPP\xampp\htdocs\testrail\app\plugins\defects\Trac.php
Line: 423
Status Code: 500
Url: /testrail/index.php?/defects/ajax_prepare_push (POST)

PHP: 5.3.5
Server: Windows NT 6.0 build 6002 (Windows Vista Business Edition Service Pack 2) i586
Browser: Opera/9.80 (Windows NT 6.0; U; Edition Next; en) Presto/2.8.158 Version/11.50

status_id: 1
assignedto:
comment:
attachments:
version:
elapsed:
defects:
test_ids: 1
_token: 92d187d0220c6f39022007a9728d178f[/code]
I must admit I don’t know what I’m looking for to begin diagnosing. I’ve tried ‘known invalid’ login settings, and that gives different results - a longer pause when ‘Push’ is clicked, and an error of ‘401’ rather than 404. To me, this at least confirms the username and password is right.

I’m using Trac 0.11.7


Trac integration 502 error
#2

Hovering over defect links causes the same 404 error.
Heres a screenshot…
http://chrisjlocke.co.uk/?attachment_id=4


#3

Hi Chris,

Thanks for your posting. The error is likely caused by the fact that the Trac web service API is not installed. This is a separate Trac plugin that you need to install first. TestRail uses the API to push bug reports and look up issues. You can learn more about Trac’s XML-RPC API on the following website:

http://trac-hacks.org/wiki/XmlRpcPlugin

The link also contains the installation instructions for the plugin. Please let me know if you have any further questions about the API.

Thanks,
Dennis


#4

Aah, that would explain it. Re-reading the plugin page, I saw a great big yellow box on the front explaining the XmlRpc plugin was required. Sorry about that.

Thanks for your assistance. I can confirm its now working perfectly! We’re getting an index error now, but suspect thats more of a Trac thing, than a TestRails thing, as it only happens on ‘old’ tickets, and gets resolved once a ticket has been edited, so not a show stopper.


#5

Hi Chris,

Thanks for the update and glad to hear that it’s working now. We haven’t seen such an Index error returned by Trac before, but it could certainly be a problem with how ‘old’ tickets are stored in Trac’s database or similar.

Just let me know in case we can help with anything else regarding the integration or TestRail in general.

Thanks,
Dennis


#6

Hi Dennis,

I am setting up a testing system TestRail + Trac for my corporate. Eveything seems to be fine until I reached to this point.
‘Push’ never worked for me. I had also followed http://trac-hacks.org/wiki/XmlRpcPlugin to install the required plugin. Plugins page in Administration section on Trac (http://server-pc:8090/admin/general/plugin) also reflects that succeeded installation.
But still, the HTTP 401 is taking me whole day.

Please advise so that I can bring this wonderful system to management to get the payroll for it.

Thanks,
Pop


#7

Hello Pop,

Thanks for your posting and for the feedback. I will email you separately to request more details about the configuration settings you have entered so we can help you get the integration up and running.

Thanks,
Dennis