Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

TestRail version 5


#1

Hi All,

Just a query… I’ve been using version 4.0.3 of TestRail and recently since having to have my work PC rebuilt, I have not been able to push defects into JIRA. This has only recently started happening (I am looking at version 5). If anyone out there trialling or already using version 5 get the same “JIRA_REST… 401” error message or have you not experienced it yet.

Asking as I am completely at a loss. Personally I think it’s because of the new PC build I have been forced to use, but I might be overlooking something.

Thanks in advance


#2

Have you checked out this thread for some basics on the 401 error?


#3

Yup, have gone over this a number of times, even restarted the TestRail server… I think I will leave it alone for now as I’ve been going over this for the past 3 hours… hopefully come back to it tomorrow. maybe a refreshed mind might help. :weary:

Thanks BGanger


#4

Hi there!

TestRail 5.0 didn’t introduce any changes regarding the push/look up integration itself, so the update would be unrelated. Usually the main issues are:

  • You tried to use your JIRA email address instead of your actual JIRA username for the integration (this wouldn’t work, as JIRA requires your actual username)
  • The JIRA password you have configured in TestRail is not correct (anymore)
  • You don’t have permissions for the configured user in JIRA to look up or push issues

I hope this helps!


#5

Update to my original issue. It seems removing the entire integration customisations and re-inserting them have made all the difference. I’m not sure what the problem was, but thankfully can now raise defects again using the ‘push’ functionality.

Will see how it goes of the next few days.

thanks to both of you for your suggestions. :relaxed:


#6

Great to hear that it works now! :smile:

Cheers,
Tobias