Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

TestRail Server 5.6.0.3856 (Patch) Released


#1

TestRail 5.6.0.3856 has been released today. It’s a server patch release with a fix for an installation issue experienced by some customers when attempting to install TestRail on a PHP 7.3 server.

The issue has now been fixed, but please note that as per our 5.6 release notes here, PHP 5.6 is no longer supported as an installation environment, and we don’t yet support PHP 7.3. Our recommended PHP versions are PHP 7.0 to 7.2.x.

Getting the new version

Updating to the new version

You can update to the new version as usual by installing it over your existing TestRail installation (there’s no need to uninstall your existing installation). The database upgrade wizard is automatically started when you access TestRail with your web browser. Please see the update instructions for details: http://docs.gurock.com/testrail-admin/installation-upgrading/

As usual, we heartily recommend you take the time to make a backup of your current installation before upgrading to the new version.

Cheers,
Simon


#2

Link in 2nd bullet is invalid (http://www.gurock.com/go/portal/)


#3

Hi @nbl9999,

Thanks for catching that. The link should be http://www.gurock.com/portal/ and has been corrected in the post.

Regards,
Jon


#4

Hi Gurock Team,

We have a problem with the new version TestRail v5.6.0.3853
Would it be solved in this version?


#5

Could you add the version for the self hosted installation to the notes? We have 5.6.0.3841 so I am going to assume we are 2 patches behind?