Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Testrail-Jira Integration fails


#1

Hello All,

We have a problem with Testrail -Jira integration .We are able to push /add defects to Jira from Testrail ,but same not reflecting in Jira .In jira issues ,under TestRail results , its empty .All settings has been done as mentioned


#2

Hi Akhil,

I presume you have installed the Jira TestRail Plugin? If not, give this a try and it should work.

Are you using the cloud or on premise version of TestRail? If yes, what version of Jira are you using? It might be worthwhile seeing if there are any errors written within the Administration>System Log section of TestRail.

Here is a link to another forum post that might help you - Integration key - where to find it?

Thanks,
Bryan


#3

Hello Mr Bryane,

Thanks for the updates,

Please find the details below

Jira Version : 7.1.6

TestRail Version - 5.2.0.3452

TestRail for JIRA Test Management : 1.0.1.99-70


#4

Hi there,

Please make sure that you have the add-on configured to show the login prompt if the user is not logged into TestRail as well. If not, then you will simply see a blank section as you are seeing.

This setting is found in JIRA under the TestRail for JIRA Test Management add-on configuration.


#5

Hello ,

How we can check this ? and regarding integration key ,is it user based ? if yes then how this will work for multiple users . Can you please explain little regarding the integration key also .


#6

Hello all,

can you please suggest how to proceed


#7

Hi,

Can you confirm what error you are getting in the System Log. This can be found within Admin>System Log.

The guide on integration with Jira can be found here - http://docs.gurock.com/testrail-integration/tools-jira or http://docs.gurock.com/testrail-integration/tools-jira-server

When you installed the add-on from Atlassian marketplace, did you generate the integration key? You need this in order for two way integration.

Thanks


#8

Hi Akhil,

Thanks for your reply! The integration key wouldn’t be per-user and this would just be per JIRA instance. I believe we also discussed this via email as well and if you’re still experiencing issues with this we can continue to troubleshoot this via e-mail directly to contact@gurock.com

Hope this helps!

Regards,
Marco


#9

Hello Mr Marco ,

Thanks for your response

Sure ,we can discuss through email .I have updated the status via email .Kindly check

Regards
Akhil


#10

Hi Akhil,

Thanks for the update! I’ll be responding via email shortly!

Regards,
Marco


#11

Has this issue been resolved? I am seeing the same thing in our suite.