Subscribe Join 180,000+ subscribers and receive articles from our blog about software quality, testing, QA and security. Subscribe

TestRail 6.7.2 Released

TestRail 6.7.2 has been released with various bug fixes and minor enhancements:

Bugfixes

  1. Missing edit link on Test Runs/Plan
  2. Unable to use “Forget User” function or set a user to inactive: “Call to a member function getIntegrationKey() on null”
  3. Reports: Unable to generate reports on 6.7.1 (Server only)
  4. CTRL+C Shortcut Interferes With OS Operation
  5. Text with bullets are drag-able and not selectable
  6. Error: “count(): Parameter must be an array or an object that implements Countable” reported when opening test cases
  7. Content-Type header should not be required in API GET requests
  8. When updating test case using import XML then newly qualified test case does not get added in Dynamic TestRun
  9. ‘Updates’ tab appears in TestRail Cloud Administration Area
  10. Hovering on Defect and Reference link will not display all information in Classic Theme
  11. Unable to move cases using drag and drop or bulk edit feature
  12. Changing custom dropdown field values while bulk editing test cases does not automatically select the field to be updated
  13. Text not completely visible in ‘User’ dropdown in ‘Select User’ dialog for Classic and Dark themes.
  14. Unable to select value in custom dropdown in Result Dialog field when menu exceeds dialog size (Chrome only)
  15. SMTP without encryption or authentication will not work on TestRail 6.6
  16. Editing the Default User Role clears the default property
  17. Dropdown display issue under “Assign To > Assign all in filter” using Dark and Classic theme
  18. Error: “An Error Occurred Too few arguments to function User_model::insert_ex()” during AD login

Enhancements

We introduced some database improvements which will enable the rolling back of a TestRail installation if necessary. The rollback will only work from this release though, so don’t try that out just yet!

Rollback instructions can be found on the docs site, here: https://www.gurock.com/testrail/docs/admin/installation/downgrading

Getting TestRail 6.7.2

A 14-day trial version of TestRail can be requested here (hosted on our servers or as download to install on your own server): http://www.gurock.com/testrail/trial/

If you want to create a subscription for TestRail Cloud, you can do so from within TestRail via Administration > Subscription . Or, if you want to order TestRail Server licenses you can do so from our website here: Purchase & Buy TestRail Licenses

Registered customers can download the full version from our customer portal: http://www.gurock.com/portal/

Updating to TestRail 6.7.2

TestRail Cloud instances are automatically updated to the latest version. You can check your version via the TestRail Help > About TestRail menu item.

Docker and on-premise versions of TestRail will be released shortly. We will update this post once they are ready to ship.

TestRail Enterprise

If you’re interested in TestRail Enterprise, please email us for a trial or quote via contact@gurock.com, or you can use the contact form here: https://secure.gurock.com/customers/support/

1 Like

TestRail version 6.7.2.1037 is now available for server instances.

If you are using the on-premise version of TestRail, you can update to the new version as usual by installing it over your existing TestRail installation (there’s no need to uninstall your existing installation). The database upgrade wizard is automatically started when you access TestRail with your web browser. Please see the update instructions for details: Installation - Upgrading TestRail - TestRail

Please ensure you make a backup of your current on-premise installation before upgrading to the new version.

Edit: As noted by @PHeginbotham in the comments below, if you’re using Windows Server, you’ll need to ensure the correct php_pdo_sqlsrv.dll library is enabled by adding the appropriate extension to your php.ini config.

Hey,
It looks like database upgrade for on-premise version is going to take more than expected. run.php is updating from 305 to 20210201143005
Is that expected and something that we should calculate in downtime for an upgrade?

Hi @Predrag - the DB version is now a timestamp rather than an ID, due to the introduction of rollback capability. The upgrade process shouldn’t take any longer than usual.

Please do take a backup first though!

On an on-premise Windows installed we had a failed upgrade RunTimeExeption You need to enable the PDO_Dblib extension for Phinx to run properly

Is there a requirement to add to the following line to the php.ini
extension=php_pdo_sqlsrv_72_nts_x64.dll

Hi @PHeginbotham - yep, you’ll need to install the appropriate php_pdo_sqlsrv.dll library for your Windows Server PHP architecture by providing it in the php.ini config.

My apologies for missing this out of our documentation. :disappointed:

Adding extension=php_pdo_sqlsrv_72_nts_x64.dll fixed the issue

This allowed us to click these issues

  • SMTP without encryption or authentication will not work on TestRail 6.6
  • Reports: Unable to generate reports on 6.7.1
1 Like

6.7.2 now available on Docker also.

When attempting to upgrade to 6.7.2 from 6.7.1 we get the following error:

PHP error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 3219144704 bytes) in /testrail/web/app/views/update/progress.php at 43

(At /index.php?/updater/index)

This is even after bumping memory_limit from 128M to 4096M.

@mmh - that’s a bug! Thanks for flagging it. We are working on a fix…

This has not been the case for our upgrade cycle. We were upgrading from 6.1 which started at around database_version 193 and it ran over 12 hours and never made it up to the timestamp. I went in and made the timestamp adjustment manually and seemed to have arrived at a final working state.

Our Docker TestRail is also unavailable now due to the same error.

@jonny

Apologies for the inconvenience caused. We were made aware of this issue in the system and our team is currently working on a fix.

Stay tuned for more updates on this.

Regards,
Shanu

@jonny We had the same error using docker as you have.
We were able to easy rollback to the previous working version using backups before upgrade. This might be an option for you

Happy to know that you are working on a fix Gurock, thanks!

I got the same error when attempting to upgrade. Hope you fix it soon

OMG! bug after bug!
Same error! Please fix this ASAP. Testrail is broken %(

same error for me also

I see new image of testrail was released several minutes ago.
But anyway, it’s the same error:

PHP error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 82460672 bytes) in /var/www/testrail/app/views/update/progress.php at 48

It’s still 128Mb in php.ini
cat /usr/local/etc/php/conf.d/php.ini | grep memory_limit
memory_limit = 128M

UPD: looks it was because the image tag hasn’t changed. I removed old images from the server and pulled new one.
But now it’s another error:

Migration failed with the error: Phinx by CakePHP - https://phinx.org. using config file /tmp/version_update8GYbqX.json using config parser json using migration paths - /var/www/testrail/db/migrations using environment production using adapter mysql using database testrail ordering by creation time RuntimeException: You need to enable the PDO_Mysql extension for Phinx to run properly. in /var/www/testrail/vendors/phinx/Db/Adapter/MysqlAdapter.php:95 Stack trace: #0 /var/www/testrail/vendors/phinx/Db/Adapter/PdoAdapter.php(162): Phinx\Db\Adapter\MysqlAdapter->connect() #1 /var/www/testrail/vendors/phinx/Db/Adapter/PdoAdapter.php(222): Phinx\Db\Adapter\PdoAdapter->getConnection() #2 /var/www/testrail/vendors/phinx/Db/Adapter/PdoAdapter.php(238): Phinx\Db\Adapter\PdoAdapter->query(‘SELECT * FROM ...') #3 /var/www/testrail/vendors/phinx/Db/Adapter/PdoAdapter.php(376): Phinx\Db\Adapter\PdoAdapter->fetchAll('SELECT * FROM …’) #4 /var/www/testrail/vendors/phinx/Db/Adapter/PdoAdapter.php(348): Phinx\Db\Adapter\PdoAdapter->getVersionLog() #5 /var/www/testrail/vendors/phinx/Db/Adapter/AdapterWrapper.php(204): Phinx\Db\Adapter\PdoAdapter->getVersions() #6 /var/www/testrail/vendors/phinx/Migration/Manager/Environment.php(260): Phinx\Db\Adapter\AdapterWrapper->getVersions() #7 /var/www/testrail/vendors/phinx/Migration/Manager.php(312): Phinx\Migration\Manager\Environment->getVersions() #8 /var/www/testrail/vendors/phinx/Console/Command/Migrate.php(123): Phinx\Migration\Manager->migrate(‘production’, 20210201143005, false) #9 /var/www/testrail/vendors/symfony/console/Command/Command.php(256): Phinx\Console\Command\Migrate->execute(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput)) #10 /var/www/testrail/vendors/symfony/console/Application.php(971): Symfony\Component\Console\Command\Command->run(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput)) #11 /var/www/testrail/vendors/symfony/console/Application.php(290): Symfony\Component\Console\Application->doRunCommand(Object(Phinx\Console\Command\Migrate), Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput)) #12 /var/www/testrail/vendors/phinx/Console/PhinxApplication.php(69): Symfony\Component\Console\Application->doRun(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput)) #13 /var/www/testrail/vendors/phinx/Wrapper/TextWrapper.php(239): Phinx\Console\PhinxApplication->doRun(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput)) #14 /var/www/testrail/vendors/phinx/Wrapper/TextWrapper.php(117): Phinx\Wrapper\TextWrapper->executeRun(Array) #15 /var/www/testrail/sys/libraries/migrations.php(76): Phinx\Wrapper\TextWrapper->getMigrate(NULL, 20210201143005) #16 /var/www/testrail/app/models/update.php(120): Migrations_library->getMigrate(20210201143005) #17 /var/www/testrail/app/controllers/updater.php(233): Update_model->migrate(251, 20210201143005) #18 /var/www/testrail/sys/base/controller.php(257): Updater_controller->ajax_run_migration() #19 /var/www/testrail/sys/base/controller.php(168): Controller->_invoke_web_call(Array, ‘ajax_run_migrat…’, Array) #20 /var/www/testrail/sys/base/controller.php(120): Controller->_invoke_web(‘ajax_run_migrat…’) #21 /var/www/testrail/sys/core/gizmo.php(129): Controller->_invoke(‘ajax_run_migrat…’) #22 /var/www/testrail/index.php(114): require_once(’/var/www/testra…’) #23 {main}

on a second server it failed with same RunTimeExeption You need to enable the PDO_Dblib extension for Phinx to run properly even though the PHP.ini was updated

Thanks for your reports. We will provide an update as early as possible.

Regards,
Shanu

1 Like