Subscribe Join 180,000+ subscribers and receive articles from our blog about software quality, testing, QA and security. Subscribe

TestRail 6.6.1 Released with Various Bug Fixes

TestRail 6.6.1.1166 has been released with various bug fixes and minor enhancements:

Bugfixes

  1. GitHub - Undefined Index Email error after upgrade to 6.5
  2. Empty spaces before SSO certificate
  3. Test Case string and text fields are displayed incorrectly in Edit and Create case screens
  4. Azure DevOps - Cloud Defect Plugin shows incorrect address configuration
  5. UI - Searchable Drop-downs - Dark Mode text in search box is not visible
  6. Not able to select Sprint value under the “Push Defect” dialog box for the “Next Gen” project
  7. When the API “get_attachments_for_plan_entry” running without existing test plan id or entry it will not return error code
  8. ‘Update’ action does not get logged for EntityType ‘Test’ , when user change the title for related ‘Case’ entity
  9. Dropdown, Multi-select, and user fields are not displayed properly in result dialog when case field has same system name
  10. UI - Some dropdown fields displayed too large
  11. Text fields under test case screen displayed incorrectly while editing the “Templates” value
  12. Importing Exported XML, getting error “Trying to get property ‘section_id’ of non-object”
  13. Testcase added or updated by CSV or XML Import does not get added in Dynamic Filter TestRun
  14. Safari Browser - Tab key not working for dropdowns across all screens
  15. Large tables are not displayed in TestRail UI
  16. “Assign all in filter” unassigning the user
  17. On click of Defect tab, error message is seen - The specified column is not available in the result
  18. Size of the “Milestone dropdown” field gets broken while Add/Edit the test case and change template type
  19. Jira Defect Plugin: get_assignees is called when pushing defects even if assignee is set to off
  20. get_users/project_id - The database result has more than one row error
  21. Dropdown not clickable in fast track edit case mode
  22. Searchable drop-down menus require mouse usage
  23. TestRail version 6.5 does not show the “Status” field when I hover over a Jira bug/reference ID in the test result
  24. Showing an error “Plugin Jira_Cloud_REST returned an error: priority: Field ‘priority’ cannot be set”
  25. Jira field “Sprint” value is not showing on Hover/Reference field
  26. Test case not added in ‘Test Run’ after adding removed selected dynamic filter option from customization
  27. Test case not removed from ‘Test Run’ after removing selected dynamic filter option from customization
  28. “DOMDocument” error appearing while open the existing test case
  29. Azure Devops Cloud - Default Configuration missing default fields system_info and repro_steps
  30. overall test status does not change to failed when changing a test step to failed
  31. Tab key not working in fast track mode for test cases

Getting TestRail 6.6.1

A 14-day trial version of TestRail can be requested here (hosted on our servers or as download to install on your own server): http://www.gurock.com/testrail/trial/

If you want to create a subscription for TestRail Cloud, you can do so from within TestRail via Administration > Subscription . Or, if you want to order TestRail Server licenses you can do so from our website here: https://secure.gurock.com/customers/shop/annual/purchase/

Registered customers can download the full version from our customer portal: http://www.gurock.com/portal/

Updating to TestRail 6.61

TestRail Cloud instances are automatically updated to the latest version. You can check your version via the TestRail Help > About TestRail menu item.

Docker and on-premise versions of TestRail will be released shortly. We will update this post once they are ready to ship.

TestRail Enterprise

If you’re interested in our Enterprise package, please email us for a trial or quote via contact@gurock.com, or you can use the contact form here: https://secure.gurock.com/customers/support/

6.6.1 Server version is now available for download.

Docker image now available also.

Hi! It seems to be a bug in this version.
Testcases page. When using drag’n’drop case moving URL index.php?/cases/ajax_move_confirmation returned 500 error. So i can’t do moving.
What’s a reason it may be?.. Thanx in advance.

Hi @lvovaa - we’ve had a couple of reports of this behaviour. We’re looking into it.

I’m just noting this here as apparently support say this is an issue.
After upgrading the docker version to 6.6.1 we are unable to use a self hosted email server to send emails.

This server sits on port 25 and doesn’t require authentication.

Connection could not be established with host our-email.server.com :stream_socket_client(): unable to connect to none://our-email.server.com:25 (Unable to find the socket transport "none" - did you forget to enable it when you configured PHP?)

I have exactly same issue. My smtp server is okay, same as docker container. Testrail was working great and sending mail in 6.5

@Brightside @jonny

This is a known issue within the system currently and our team is working on a fix as early as possible.

While we don’t have an exact ETA yet as to when this will be resolved, the current workaround for this (as suggested by our Support Team) would be to use a 3rd party setup as SMTP Relay, such as Sendgrid.

Let me know if you have any additional questions.

Regards,
Shanu

Well. I’m using 3rd-party smtp endpoind and it’s not working :man_shrugging:

For me, e-mail was working after upgrading to 6.6.1 until I added a custom logo. Once I added a logo, I started getting:

Connection could not be established with host our-email.server.com :stream_socket_client(): unable to connect to none://our-email.server.com:25 (Unable to find the socket transport "none" - did you forget to enable it when you configured PHP?)

@sjpknight We have the same problem(testrail 6.6.1), any suggestions for solving it? Thanks

@grigory.komov

Hey Grigory,

Thanks for your post.

The fix for the issue you mentioned is currently in development/testing. As such, I can’t give you a precise timeline for release, but I expect it to be very soon.

Regards,
Shanu

Hi Shanu, We are having the same issue at Gwinnett County Public Schools. Please let me know if you have an update on this.

@jmadduri

Hey Jitendra,

Welcome to the TestRail Community and thanks for your post. The aforementioned issue is in testing phase currently.

However, stay tuned for more updates on this here : TestRail News - TestRail Community & Forum

Regards,
Shanu

We also got this problem after we changed the name of the mail server. We are waiting for at least a temporary solution, without using third-party applications.

1 Like

@jonny @Brightside @randyb @grigory.komov @jmadduri @nekrasovam

Hello everyone,

Thanks for your patience. The fix for this issue is live now. Please check out the release notes (Bug Fixes #15) here.

Please let me know in case of any additional questions.

Regards,
Shanu

1 Like

Thanks for the update Shanu, I appreciate it.

Good afternoon! Did you manage to fix this error ?

@Ildar

Hello,

Could you please help me understand which error are you referring to?

Regards,
Shanu

Hello, @shanu.mandot, I need to fix this issue