Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

TestRail 5.4 released


#1

Hello!

TestRail 5.4 is now available. The new version is a platform release and adds support for PHP 7.0, Windows Server 2016 and SQL Server 2016. Please see below for the full list of changes:

  • Added: Support for PHP 7.0
  • Added: Support for Windows Server 2016 and SQL Server 2016
  • Added: Auto-set Elapsed field based on current timer of user for Pass & Next with three-pane view
  • Changed: Order upcoming test runs & plans in Upcoming section on Test Runs & Results page by start date & name per group
  • Fixed: Upcoming section on Test Runs & Results may show groups of upcoming test runs & plans in incorrect order
  • Fixed: HTML characters in URLs in markdown tables may be double-encoded
  • Fixed: Deleting milestones with sub-milestones does not unlink the parent
  • Fixed: TestRail for JIRA integration may not respect remember-me cookie and shows login button/empty page without valid user session
  • Fixed: Possible “A non well formed numeric value encountered” error with date range filter when opening Select/Copy Cases dialog (e.g.
    on test plan form or cases page)
  • Fixed: Possible “Field Case IDs is not a valid ID list” error if rerunning a test plan with deleted cases and changing the test case
    selection
  • Fixed: Validate project for templates for add_case/update_case (v2 API)
  • Fixed: Add Result dialog may be opened with an incorrect background color if the default status is not Passed
  • Fixed: Error messages during update/installation may use incorrect colors

Getting the new version
A 30-day fully functional trial version of TestRail can be requested here (hosted on our servers or as download to install on your own server):

http://www.gurock.com/testrail/trial/

If you want to order TestRail, you can do so directly in our online shop:

http://www.gurock.com/order/

Registered customers can download the full version from our customer portal:

http://www.gurock.com/go/portal/

Updating to the new version
All accounts of TestRail Cloud already use the new version.

If you are using the download version of TestRail, you can update to the new version as usual by installing it over your existing TestRail installation (there’s no need to uninstall your existing installation). The database upgrade wizard is automatically started when you access TestRail with your web browser. Please see the update instructions for details:

http://docs.gurock.com/testrail-admin/installation-upgrading/

Please take the time to make a backup of your current installation before upgrading to the new version.

Cheers,
Tobias


TestRail 5.4 no release notes
#2

Get an error after copying 5.4 files.

An Error Occurred
PHP error: The file C:\inetpub\wwwroot\testrail\app\config\consts.php cannot be decoded by this version of the ionCube Loader. If you are the administrator of this site then please install the latest version of the ionCube Loader. in Unknown at


#3

Thanks for your posting. Please use the correct TestRail download/ZIP for your PHP version. There are different downloads for PHP 7, 5.3 and 5.2 and they all use a different ionCube version and target a different PHP environment. The most commonly used download ends with “ion53.zip”. “ion70.zip” is only for PHP 7 and “ion51.zip” for PHP 5.1/5.2.

I hope this helps!

Cheers,
Tobias


#4

I would like to verify that there were no db updates in this version - correct?

Thanks,

Brian


#5

From what I have seen in the documentation there were no changes made.


#6

Thanks Marty for the confirmation.


#7

No PHP 7.1 support yet?


#8

Hi Glenn,

Thanks for your reply! That’s correct, currently TestRail 5.4 would support up to PHP 7.0.x, and you can also review the full list of requirements and supported versions on our website here:

http://docs.gurock.com/testrail-admin/installation-requirements

Hope this helps!

Regards,
Marco