Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Test rail integration: bundle permissions when pushing?


#1

Hey all,
I tried to look over the forum to see if I could find this issue but I couldn’t see it - sorry if I am duplicating a support question.

I’m just setting up our test rail instance and trying to get it integrated with you track. I’ve got everything linked up nicely in terms of referencing issues but I have come into an issue when using the push feature.

I am trying to push and I receive this error:

Plugin “YouTrack20184” returned an error: You have no permissions for bundle [ Types ]

I was wondering if anyone could help me before I email support?

Thanks in advance.


#2

Hi @lb1987,

Thanks for the post! The TestRail integration and push dialog with YouTrack utilizes YouTrack’s API, and this error message is the response received from YouTrack’s API when trying to push data.

You may find additional details about this on the YouTrack support site. I was also able to locate a small discussion on their forum for the same error message:

https://youtrack-support.jetbrains.com/hc/en-us/community/posts/206583155-You-have-no-permissions-for-bundle

I hope this helps,
Jon


#3

Hi Jon,

Thanks for the reply, I found that post previously but the link is dead.

Thank you for the response though


#4

Hi @lb1987,

Thanks for the feedback! It looks like the details for permissions management have renamed to ‘Access Management’ within YouTrack’s documentation. You might find the following links helpful:

https://www.jetbrains.com/help/youtrack/standalone/Access-Management.html

https://www.jetbrains.com/help/youtrack/standalone/manage-project-access.html

Hope this helps,
Jon