Subscribe Join 180,000+ subscribers and receive articles from our blog about software quality, testing, QA and security. Subscribe

SQL Error Windows Installation

Hey Guys,

I’m currently trying to set up an TestRail on prem Installation using Windows Server and MS SQL, i fixed a lot of errors myself and also your documentation is pretty decent (thanks for that).

Unfortunately I run into the following error:
image

The Error basically states that the Objext “dbo.entity_attachments” could not be found because it’s non existant or missing permissions.

Could / should i manually create that Object or is something generally wrong with my setup.

Thanks in advance and best regards
Markus

I am going to guess that it is referring to the Attachment folder you create to store attachments on the server. It should have been created by you at the same time the Report folder was created on the server.

Hey @BGanger,

yeah I created the folder as specified, outside of the IIS root directory…Folders are writeable and I set the permission for IUSR according to the documentation…

Thanks and regards

@Kaotes

Hey Markus,

Welcome to the TestRail Community !

Glad to hear, the error is not a blocker anymore.

Thanks,
Shanu

@shanu.mandot

Hi Shanu,

oh that’s unfortunately not the case.
I was just confirming that I followed all the steps that are documented and I still get the above error, therefore the error still is the block for our TestRail Implementation…

Thanks and best regards

//Edit: Thanks for the hearty welcome =)

@Kaotes

Hey Markus,

Oh ! I see.
I would suggest you to send an email to contact@gurock.com so that our Customer Support Team can assist you in fixing this issue ASAP.

Thanks,
Shanu

@shanu.mandot
Hey Shanu,

yeah I did that earlier today, looking forward to hear from the Team =)

Thanks for your support!
Best regards,
Markus