Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.

Reports running endlessly (apparently)


I’m not sure what more information to provide.

I’m trying to run a report in a project that has about 1400 testcases (over 100 or so sections).

My first report was a Property Distribution report; using default values.
Then I tried a Property Distribution report; adding a few columns but disabling “test details per group”

Then, thinking it was that specific report template, tried a Milestone report on one of our milestones.

All are in the “generating” state (i assume that’s what it is, as the little gif is still going back and forth on the report tab). I can’t click on them.

Not sure how to debug this. These have been in this state now for 2 hours.

This is a hosted trial instance. The testcase ids are at 537,000+ (i’ve been adding/deleting/exporting/importing quite a bit during this eval); but again there are only about 1400 testcases in this project, and maybe 8000 total across all projects.

Let me know what else I can do.


Hello Jim,

Thanks for your posting.

The issue is likely that you haven’t yet activated TestRail’s background task on the server. The background task is responsible for computing TestRail’s reports as well as processing email notifications and other tasks.

You can verify the status of the background task under Administration > Overview. You can learn more about activating the background task here:

You can also clear the email queue before activating the background task via the little link on the administration overview page, next to the queue background task’s status (this prevents any queued emails to be processed, which could be hundreds of emails or more).


Report Hangs - Won't Stop Running

Thanks for the reply.

This is a cloud-hosted instance (ie; you are hosting it).

The admin page says the background task is turned on. And actually my reports finally did finish; but not until I gather the background task kicked off via cron; which since it’s hosted I don’t have access to.

It looks like maybe it’s only happening every 12 hours? The reports say they were done at 6:38am; and the last background task was executed at 6:38pm (I also have a feeling those times are not in my timezone).

I just ran another report and it’s again waiting; so I don’t think there is anything I can do to force the task to start (from the GUI). The link you mentioned above is only if you have access to the instance shell itself, which I do not.



Sounds like you are having a similar issue that we had. We never managed to get to the bottom of it.

Tobias / Dennis, the reference ID on the email we sent about this to was 31334 (if it helps).


Thank for the additional details! We will make sure to look into this and get back to you via email.



I am having the same issue. I am trying to determine what reports are going to work for us and waiting so long for the results is making this process frustrating. We are hosted locally and the background service is running (reports are eventually finishing). Has this been resolved yet?


Hello @joannanegler,

Generating reports only takes a few seconds so if it takes longer for you then the background task is not executed/triggered once every minute correctly. It’s important to execute the task once very minute:

If the background task is only triggered e.g. every 30 minutes, then it takes a long time until it starts processing the report of course and you see this “delay”. You can simply check this by taking a look at Administration > Overview and verifying if the “Last run” time is updated every minute. If it isn’t then this indicates that the Cron job or Windows Scheduled Task isn’t correctly configured.


The background services is set to run every 5 minutes. I will change it to 1 minute to see if that helps.

Report generation issue

Hello Joanna,

You can also look into increasing the memory limit of your PHP installation (which might be hit for very large reports otherwise):