Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Reports never gets generated on selecting All Test Cases


#1

Hello,

I am trying to generate a report ( Run Report ) for all the test cases in my Test Suite that were part of the test run but I am finding that the report is not getting generated at all even on waiting 24 hours.


#2

Can you generate reports at all? If the manual report cannot be generated, either, maybe the cofiguration of the background task is wrong.
Under Administration you can check when the task ran last.

It could be that the task is not running every 24 hours.


#3

I have exactly the same issue when select report 1000/All tests in the Run. At the same time it works perfectly if I select 500 or less for the same report. I tried with a few projects and got the same result - reports never get generated.

How that can be fixed?


#4

I can generate reports if the TC count is less than 250. If I select add
all TC’s or 500 or 1000 TC’s reports never gets generated. I have around
800 Tests in my Test Runs that I need to report on every week.


#5

Last run is
Last run 4/17/2017 9:17 AM


Report showing an eternal spinner when opened
Test report does not generate report when I select all test cases to display
#6

Hey kduggal,

Thank you for the post. Based on your description, it sounds like you are hitting the PHP memory limit. If this is TestRail Server, you can increase the PHP memory limit by editing your php.ini file. Instructions are located here:

http://docs.gurock.com/testrail-faq/system-memory-limit

You can also opt to set this to unlimited. To do this you would use the following: -1

If this is TestRail Cloud and you are still having this issue, we would recommend breaking up your report in to several smaller reports.


Background task installed but reports not generated
#7

Thank you Marty,
Changing the memory limit to unlimited seems to have resolved the problem for now. However it does appear that doing so it could drain all the memory from the server running on 2GB RAM and could result into server not responding. Do you have any thoughts about if that is a side affect of setting the memory limit to -1.


#8

Hi kduggal,

Thanks for your reply! If this is indeed the case, and if you plan to run many similar large reports in the future, then we would just recommend increasing your system memory to help with generating these. The PHP limit is quite low by default, so if you jumped straight to Unlimited then you may opt to decrease it again from Unlimited to a more safe number such as 512mb, or slightly more if you already tried this. This would ensure your system doesn’t crash when generating the report. Hope this helps!

Regards,
Marco