Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Report generation hung


#1

We are using TestRail 5.2.0.3452. The report generation has stopped working. The background task is installed and running. When I try to initiate a report, a new entry appears, with the busy activity icon. The activity icon oscillates back and forth forever, and the report never completes. No entry is made in the reports directory on the server. What can I do to diagnose this further?


#2

Hi Phil,

Thanks for your posting. Can you please double-check that the background task is triggered regularly (e.g. every minute)? You can check this under Administration > Overview. Does this happen with every report you create or just a few reports?

Cheers,
Tobias


#3

Status is Idle (not locked, 0 messages). Last run 5min ago.

It happens for all reports that I’ve tried, including Plan (Summary) and Summary for Reference. It happens on multiple projects. It looks like this problem has existed since April, as the last report was saved on 22-Apr.


#4

Regular email messages, such as assigning tasks to users, are being sent OK. It’s just the reports that are not working.


#5

Hi Phil,

Thanks for the additional details. This may be a memory limit related issue and there are two ways to troubleshoot this. Depending on your system (Linux vs. Windows) and the way you trigger the background task (e.g. cron), it is usually possible to see memory related errors in the trigger logs (e.g. cron). Another way to troubleshoot this is to enable TestRail’s debug logging:

http://docs.gurock.com/testrail-faq/system-debug

We can also recommend disabling or increasing the memory limit (especially for the background task):

http://docs.gurock.com/testrail-faq/system-memory-limit

Cheers,
Tobias


#6

Increasing the memory_limit from 128M to 512M has solved the problem. Thank you!


#7

That’s great to hear, Phil, and thanks for the update :slight_smile:

Cheers,
Tobias


#8

Hi tgurock,

I am also facing the same issue, I have also increased the memory size to 512 M. Still reports show “busy” sign.

Below is the system log:
[ValidationException] Field Report is not a valid report.

Details:
File: /var/www/testrail/sys/helpers/ex.php
Line: 25
Status Code: 500
Host: 107.109.111.55
Uri: /testrail/index.php?/reports/ajax_check_status (POST)

Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.110 Safari/537.36
PHP: 7.0.32-0ubuntu0.16.04.1
Server: Linux 4.4.0-135-generic #161-Ubuntu SMP Mon Aug 27 10:45:01 UTC 2018 x86_64

report_id: 7
_token: .wATnGAKZS5tfXNXWBhU
_version: 5.5.1.3746

Trace:
at ex::raise (controller.php:243)
at Controller->_prepare_invoke (controller.php:136)
at Controller->_invoke_web (controller.php:120)
at Controller->_invoke (gizmo.php:107)
at require_once (index.php:106)

Can you please help. Its urgent.


#9

Hi there,

Thanks for the post! If you’re having trouble with report generation that was not fixed with increasing the PHP memory limit, please send in a ticket to our support team at contact@gurock.com with the above information along with any additional details you can provide regarding your server set up (OS, PHP version, TestRail version, etc.) and we’ll be happy to help troubleshoot the issue. We look forward to hearing from you!