Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Problems with customfield in Jira integration


#1

Hello,

I’m setting up a Jira link from our TR instance and everything works fine with the default push.fields until I add a custom field.

Once I add a custom field, when I am selecting a Project on the Push Defect window it seems to time out and gives me a generic error. When I remove the customfield from the push.fields things are fine. The problem is that we have 3 custom fields in our Jira project that are required, so we will need to have this in the push.fields in order to Push to Jira.

Here’s my config (lines commented for various testing):

[push.fields]
summary=on
project=on
issuetype=on
component=on
assignee=on
priority=on
affects_version=on
customfield_11141=on
;customfield_11142=on
;customfield_11143=on
description=on

[push.field.customfield_11141]
label=How Found
size=compact
type=dropdown
required=true

[push.field.customfield_11142]
label=Where Found
size=compact
type=dropdown
;required=true

[push.field.customfield_11143]
label=When Found
size=compact
type=dropdown
;required=true


#2

Hello Kris,

Thanks for your posting. We haven’t seen this behavior before, so it would be great if you could answer the following questions:

  1. Which TestRail version do you use (I assume 2.7.1)?
  2. Which Jira version do you use?
  3. Could you post the concrete error message you see?

Also, it would be great if you could enable debug logging for your TestRail installation, retry the Push and then send us the log file:

http://docs.gurock.com/testrail-faq/system-debug

Please let me know in case you have any questions.

Regards,
Tobias


#3

Hi Tobias,

Jira version is 5.2.5
TR version is 2.7.1.2102

The error is: An error occurred during the last operation. Please try again or refresh the current page.

Working on getting debug logging turned on, I’ll post back as soon as I have a log.

Thanks!


#4

Log file in hand, how do I get this to you? I don’t see any way to attach it here.


#5

Hello Kris,

Thanks for the update. Please compress the log file and send it to our help desk at:

contact@gurock.com

Regards,
Tobias


#6

Email sent, thanks!


#7

Hello Kris,

Thanks for the log file. We are looking into it and try to reproduce the behavior.

Regards,
Tobias