Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Problem with Axosoft Integration (Push Defects)


#1

I am new to TestRail and just tried to integrate it with our Axosoft system (both are hosted, not on premises; the system is no longer called “OnTime” by the way but just Axosoft).

I followed instructions but when I try to “Push” a defect from the result window I get the following error:

Plugin “OnTime_REST” returned an error: Invalid HTTP code (400). Please check your user/password for OnTime.

Naturally, I checked my username/password… it is correct.


#2

Hello Peter,

Thanks for your posting. The Axosoft integration/API is a bit special in that is also needs an API client ID and secret to be configured (in addition to a standard username and password). You can generate this ID/secret combination in Axosoft’s administration area (“Tools > System Options > Axosoft API Settings”) and would need to configure this as part of the integration in TestRail (Administration > Integration).

I hope this helps!

Cheers,
Tobias


#3

Hi Tobias,
Thanks for the quick reply! I already did this (and verified that I had copied correctly) - but it did not work. There must be another reason for the problem. Did you test this with the latest version of Axo (15)? I can also send you the config via private email if you like.
Thanks, Peter


#4

Hello Peter,

Do you use the global integration under Administration > Integration or a per-project integration (Administration > Projects > edit a project > Integration)? I’m asking as the per-project integration would override the global integration and TestRail would then use the per-project settings.

We found that the Axosoft/OnTime API is stable and hasn’t really changed over the last few versions (at least the part we are using). So as long as you are using a version >= 12, the integration would work. I would recommend going through the configuration again and checking that a) the username and password is correct (e.g. your own Axosoft credentials) as well as b) the client ID and secret as generated in the Axosoft’s administration area.

I hope this helps!

Cheers,
Tobias


#5

Thanks for the quick reply.

  • I used global integration only (the project settings are empty)
  • I copied the client ID and secret three times to be sure
  • I checked my username/password by logging into Axo

Is there a way to get more debug info?

Thanks!

Peter


#6

By the way: .ontimenow.com is no longer a valid URL (timeout). The new Axo Urls are .axosoft.com. I already used this; yet it resulted in the said error. Maybe the whole URL has changed? (I also tried variants like /API/v5/ etc. but it doesn’t work)


#7

Hello Peter,

Yes, you or we can enable additional logging and this depends on the TestRail edition you use. If you are using TestRail Cloud, please send a quick email to contact@gurock.com with your contact details/TestRail address. If you are using TestRail Server instead, you can enable debug logging as follows:

http://docs.gurock.com/testrail-faq/system-debug

You would only need to enter the basic address of your Axosoft/OnTime installation without any additional API extensions or similar. So it’s just address=https://example.axosoft.com/ or similar.

I hope this helps!

Cheers,
Tobias


#8

Hello Tobias,

Thanks for all the help. I had overlooked the checkbox “Enable API” in Axosoft. Now it works perfectly - very impressive!

Thanks, Peter


#9

Hi

I have been having exactly the same issue! Except my Enable API is selected and the issue still exists. Axosoft tells me to contact Gurock and Gurock tells me to contact Axosoft! I am getting really frustrated. Please help.


#10

Hi Shirley,

Thanks for your posting! If the API is enabled in OnTime/Axosoft, this is most likely an authentication/authorization issue (e.g. incorrect username and/or password for the integration user). We will review the email and screenshots and get back to you via email.

Cheers,
Tobias