Join 34,000+ subscribers and receive articles from our
blog about software quality, testing, QA and security.

PostSharp V 3.1 Support | SmartAssembly


#1

I have tried to use your PostSharp Addin and note that it was compiled with version 2 .1 of the PostSharp library.

I have recompiled your PostSharp addin with PostSharp version 3.1 and your associated demo projects work fine. The newly compiled addin also works well with my project and I am impressed.

The issue that has now raised it’s head is that when I apply SmartAssembly’s obfuscation, your addin library crashes my program.

SI logging works OK after obfuscation and it is just your PostSharp addin that causes the crash.

I’ve searched both PostSharp and SmartAssembly support forums/manuals for guidance and the only item that refers to this is in the SmartAssembly forums which refer to one of their users having problems with adding typeof() in the aspect.

PostSharp have put the source of this problem squarely in the realm of SmartAssembly.

Is this issue already known to you?


#2

Hello Glen,

Thanks for your posting. We haven’t heard of this issue before and have you tried contacting the PostSharp or SmartAssembly support about this?

Regards,
Tobias


#3

You were the last people I notified and the response from Postsharp was to deny all responsibility and referred me to Smartassembly. They haven’t responded as of yet.

A Postsharp user found issues with the use of “typeof(…)” when using Smartassembly with PostSharp v3 aspects and reported it on PostSharp’s support pages and received the same vague response from PS.

I see where you use “typeof(…)” a fair bit in your aspects but I haven’t had time yet to go further into it.

Once I have the time I’ll narrow down the culprit and let you know.


#4

Hello Glen,

Thanks for the update, that’s appreciated. Yes, please keep us posted but I guess this is a SmartAssembly related thing we cannot do much about then.

Regards,
Tobias