Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Plugin "YouTrack" returned an error: Not Found


#1

When pushing a bug to youtrack I am receiving the error:

“Plugin “YouTrack” returned an error: Not Found”

This has only been happening recently this week.
Plugin has been working perfectly.
No changes have been made to any of the integration settings.
Using cloud based version


TestRail 5.5.1 Released
#2

Same here, integration stopped working this morning.

I’ve tested the YouTrack API via cURL and Postman and everything is working as expected. Must be something on the TestRail side.


#3

Hi - we’re looking into it. Planning to have a fix for this soon.

Cheers,
Simon.


#4

This should be fixed per release notes here: TestRail 5.5.1 Released

Cheers,
Simon


#5

Issue is still present in webapp. (https://<>.testrail.net)
Checked my version: “You are already using the latest TestRail version (5.5.1.3746)”


#6

@DaveH et al, please see thread here for an update on the Axosoft issue.


#7

How is the youtrack issue linked to Axosoft? Not sure I’m following you here?


#8

@DaveH - apologies. I think I got my plugin threads confused there! :blush:

Anyway… The plugin should work correctly, assuming you’re using the correct version - YouTrack20182. If you’re not using the new plugin version, please switch over, try again and let us know how you get on.

Cheers,
Simon


#9

Below is the version of test rail I am using.
Youtrack version is also 2018.2

TestRail (check for update) links to a 404 error
https://www.gurock.com/customers/testrail/version/check/5.5.1.3746
But I believe I am using the latest version of test rail.

Issue is still present.
Could this be an issue with youtrack rather than testrail?


#10

Hi @DaveH - I just span up a test instance of YouTrack and configured my integration plugin to use YouTrack20182 with the following settings:

  • View URL = https://<myInstanceName>.myjetbrains.com/youtrack/issue/%id%
  • Defect Add URL = https://<myInstanceName>.myjetbrains.com/youtrack/newIssue?

;Please configure your YouTrack connection below [connection] address=https://<myInstanceName>.myjetbrains.com/youtrack/ user=root password=myTopSecretPassword

Everything worked as expected my end. So, by way of next steps, I’d suggest re-checking your integration settings, including username and password settings in YouTrack. If you still can’t get it working, please reach out to our support team via contact@gurock.com and they’ll be happy to investigate further.

The 404 error when checking for an update is related to some web changes we made recently. We’re already looking into that with a fix anticipated shortly.

Cheers,
Simon