Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

New version 3.1.0.3127 and PHP 5.5


#1

Hello!

When I tried to install version 3.1.0.3126 it did not work with PHP 5.5 - the following error message was shown:

An Error Occurred PHP error: The file /var/www/testrail/app/config/consts.php was encoded by the ionCube Encoder for PHP 5 and cannot run under PHP 5.5. Please ask the provider of the script to provide a version encoded with either the ionCube Encoder for PHP 5.3 or for PHP 5.4. in Unknown at <unknown>

Is this problem fixed in the new build 3.1.0.3127?

Greetings,
Christian


#2

Hello Christian,

Thanks for your posting. Starting with TestRail 3.1, there are now two different builds (one for PHP 5.2 - 5.4 and another one for PHP 5.3 - 5.5). Please send an email to our help desk at contact@gurock.com and we will send you the link for the PHP 5.5 compatible build. We will also add the separate version as a second download to the customer portal soon.

Regards,
Tobias