Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

New testrail API needed?


#1

When I make a request for the API like

http://myserver/testrail/index.php?/miniapi/get_test/10833&key=MySecret Key

I get the response {“result”:false,“error”:“Your client version of TestRail does not match the server version (2.5.1.1623). Please refresh this page.”}

The testrail api is still the same as the 2.4 version , which was downloaded at at http://code.gurock.com/p/testrail-miniapi/downloads/19/

Is there a new API that needs to be installed for the new version of TestRail that’s not available on the API download page yet?


#2

Hello,

Thanks for your posting. Yes, we can confirm this behavior and this is a bug/problem with the 2.5.1.1623 version and has already been fixed today with a new TestRail version. If you are using the download version of TestRail, you can update your installation to 2.5.1.1626 and the API should work fine again (TestRail Hosted accounts already use the new version).

Thanks again,
Tobias