Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

New Mantis Version unable to push


#1

Dear Community,

I’ve tried to push/add from testrail to the newest version of mantis (mantisbt - 1.3.0 (Veröffentlicht 2016-07-09)

And keep getting errors, unable to push/add.

I’ve looked at the files and saw that there is no more “bug_report_advanced_page.php” in this version. I tried to upload it from a previous version but then it says:

“Plugin “Mantis” returned an error: SOAP-ERROR: Parsing WSDL: Couldn’t load from ‘http://xxxx/xx/x/api/soap/mantisconnect.php?wsdl’ : Start tag expected, ‘<’ not found”

Is there a quick fix for this?

Regards,
Steffen


#2

Hi Steffen,

The Mantis API (sometimes called MantisConnect) is often a separate package and may not be installed by default. Could you check this please?

Regarding the “bug_report_advanced_page.php”: I assume this is for the Defect Add/View URL, is this correct? If the address of the add-form has changed, you can replace this with the new address (simply open the add-form in Mantis and copy the relevant part of the URL to the Defect Add/View URL in TestRail)

I hope this helps!

Cheers,
Tobias


#3

Hey Thobias,

the API Folder is on the FTP, inside the folder there is a mantisconnect.php and and a mantisconnect.wsdl.

The bug_report_advanced_page.php is shown in your integration manual on:
http://docs.gurock.com/testrail-integration/tools-mantis

This file doesn’t exist anymore in the new mantis version.


#4

Hi Steffen,

Yes, you may need to change bug_report_advanced_page.php to the updated address and it seems that Mantis now uses a different address for the add-form.

Regarding the API: the public_html part in the URL looks wrong incorrect and can you please try this without? What happens if you do a regular CURL request against the WSDL URL (or open it with your web browser)?

Cheers,
Tobias