Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

.Net Core Support for TestRail Client


#1

I have a small test project I’d like to develop on my mac and run on a linux box to submit test results to TestRail. The client library makes things easier. However trying to run it with dotnet core produces

Package TestRail 1.0.0.12 is not compatible with netcore app1.1 (.NETCoreApp,Version=v1.1). Package TestRail 1.0.0.12 supports: net45 (.NETFramework,Version=v4.5)

Anyone know of a way to work around this issue or are there any plans to make the TestRail Client compatible with the .Net Core?


#2

Hi Kyle,

Thank you for the post. Currently we have bindings that are compatible with C# and VB.NET available here:

http://docs.gurock.com/testrail-api2/start

That being said, we are always looking into building bindings for different languages and we would be happy to look into .Net Core as well.