Join 34,000+ subscribers and receive articles from our
blog about software quality, testing, QA and security.

.net 1.1


#1

I have .net 1.1 and 2.0 on my machine and am happily testing SI with an ASP.NET-app under .net 2.0.

Now I also wanted to test it with more ‘traditional’ stuff (my main product, actually) which is implemented in “Dyalog APL” that is currently bound to .net 1.1 - and that fails with an error complaining about the format of the dll.

Of course, I just copied the .DLL I was using in my ASP.NET 2.0-project, so I can understand that msg partly. But the installer did not give me an option to install the 1.1-libraries anywhere, so what can I do to get this working with 1.1?

Thanks

Michael


#2

Hello Michael,

To use SmartInspect with .NET 1.1, you need to use the Gurock.SmartInspect.dll from the ‘lib\dotnet\v1.x’ directory of your SmartInspect installation. SmartInspect comes with different assemblies for the different .NET versions. The assembly which targets .NET 2.0 is not compatible with .NET 1.0 or .NET 1.1 applications.

The SmartInspect setup integrates the v1.x version into Visual Studio 2002 and 2003 and the v2.x into Visual Studio 2005 and 2008. To add a reference to a project in Visual Studio if the assembly is not already listed in the Add Reference dialog, you can manually select the dll it with the Browse dialog (Project | Add Reference -> Browse button).


#3

Ah, great, thanks Thomas :slight_smile: