Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Multi-select custom field problem


#1

Here’s what I did at a high level:

  • Created a project with one test suite–iOS App.
  • Created a second test suite in the same project–Android App.
  • Added a multi-select custom field with various iOS devices.
  • Discovered when I tried to edit a test case in the Android App test suite that multi-select custom fields applied to projects not just test suites. TestRail insisted that I add a value for the new custom field in the Android test case.
  • Used Admin to add an Android value to the multi-select custom field.
  • Tried again to edit a test case in the Android App test suite, but failed at this because the multi-select custom field isn’t displaying the new Android selection.

What do I have to do to get the new selection for my custom field to be displayed in the edit page for my test cases?


#2

Hello,

Thanks for your posting! Please make sure to save your custom field options after adding new multi-select options/values. We can also recommend looking into TestRail’s plans & configuration feature which use a slightly different approach to manage configurations (such as operating systems or devices) on the test run level instead:

http://www.gurock.com/testrail/videos/test-plans-configurations/

Regards,
Tobias


#3

My approach was to use ‘Add Projects and Options’ section at bottom of the Add/Edit screen to set up separate set of choices for each project (or projects). Would that help for your scenario?

Vincent.