Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Log files for errors


#1

Hi guys,

Was wondering if there are logs to look at when an error occurs in TR (currently at v4.1) on a self hosted install?

One of our users is having an issue with including screenshots and attachments (.png files, with IE11) for a test result but the message is very generic:
“An error occurred during the last operation. Please try again or refresh the current page.”

I don’t have any issue with adding a png or jpg to the same case. I can do it with FF and IE11 both without a problem. His role has the permissions to add/edit attachments as well.

I am having him try in Chrome or FF and see if he still gets the error. AS it turns out Chrome works but IE still does not…

If he continues to have problems - any logs I can look at to get any more details?

Thanks,

Brian


#2

Hello Brian,

Thanks for your posting. Yes, this is possible and you can find TestRail logs in the configured log directory (the log path is configured in TestRail’s config.php file in TestRail’s installation directory). An excerpt of the log file is also shown under Administration > System Log.

You can also enable debug logging to log additional details:

http://docs.gurock.com/testrail-faq/system-debug

The error you see can be caused by a browser plugin and this is even more likely if you only see this issue in one particular browser and for one user. If it’s a client-side issue, you won’t see any errors in TestRail’s log files but may be able to see a JavaScript error in the IE JavaScript console. I would recommend (temporarily) disabling browser plugins to see if this helps.

Regards,
Tobias


#3

Ok - thanks - they do have LastPass and will have them test it when it is disabled.


#4

The affected user disabled Last Pass to see if he could attach items and here are the results:

I am still unable to add an
image with last pass disabled.

I’ve tried both png and jpeg’s.
I’ve tried to add an image in:

  1. Test result
  2. Comment or file
  3. New case
  4. Edit case both by clicking image and clicking add attachment

We are going to make sure the extra logs are set to be created and check the console in IE.


#5

The only console we can get to is the IE Developer console which should log any Java errors and indeed - no Java errors are recorded.

I loaded LastPass on my PC for IE and I immediately have the same issue in IE as the user. So there is an issue with what/how LastPass works with IE and TR that prevents anything from being attached.

EDIT - LastPass only need to be installed for IE - it does not have to be enabled or the user logged into their LastPass account to have the issue.

Now that I have the same issue I will get with out CSS folks and see if we can find anything in the added logs. If we can’t find anything I may go ahead and send them in with a note on the date/time I tested.


#6

Hi Brian,

Thanks for the update and confirming the LastPass issue, that’s really appreciated. Please keep us updated to see if you find a solution. I would recommend using a different browser in the meantime to access TestRail, if possible (we usually recommend Chrome).

Regards,
Tobias


#7

I will pass along any info we find in any of the logs but not sure it is my job to find the solution for IE, LastPass and TR (unfortunately we are a IE/MS house).