Subscribe Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security. Subscribe

Jira Server Add on not working

Hi

I am running TestRail Server 6.1.0.4369 (up-to-date) and I asked our Jira admin to install and enable The TestRails add on.

We added the url and I created a key for it. I can see the testrails icons in Jira and on issues saying TestRail:results. But the tab is just blank. So is everything from the TestRails dropdown menu.

We then tried to adjust the configuration and not limit it to any user group in case it was a permission problem. Then she got

image

So I’m just wondering what might be the problem here exactly?

Not sure the REquires TestRail 5 or later is the issue here. But I’ve tried in chrome and firefox developer in case it was a cookie issue.

We are using LDAP for Jira and email + password for Testrail. I have configured my Jira integration within testrails to use my Jira LDAP credentials. Successfully able to report back requirements etc

Ok, I think I figured this out. My Testrails instance is over HTTP and our Jira is over HTTPS