Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

JIRA On Demand integration


#1

Trying to get the new TestRail add-on from Jira Cloud working to a local TestRail server, and I have a sort of basic question - does the TestRail instance URL need to be reachable from Atlassian Cloud? Our TestRail server is only reachable within our company network. I have successfully set up the app key and URL, but all TestRail add-on functions (for example the Projects menu item from the TestRail menu) just show a blank page (but no error).

I have the add-on set to show a login button for unauthenticated users, but the user I am using is authenticated to TestRail in another tab.


#2

Hello Fred,

Thanks for your posting! No, the actual TestRail instance doesn’t need to be reachable from JIRA and you can also use a local TestRail installation with JIRA Cloud. If you see an empty area or page for the TestRail panels/pages in JIRA, then it’s likely that your web server does not allow iframes which are used for the integration. Do you have the option to send a raw HTTP request to your TestRail server to see the response of your TestRail web server? If you have curl installed, you can do this as follows, for example:

curl -v http://<server>/testrail/

You can also send the output to contact@gurock.com if you don’t want to post it here.

You can alternatively also use the developer tools of your browser:

http://docs.gurock.com/testrail-faq/system-app-debug

Regards,
Tobias


#3

Hi Fred,

Thanks for your posting! The problem is actually pretty simple: web browsers don’t allow frames to include HTTP pages if the host application is an HTTPS site (this is a security feature of web browsers). JIRA Cloud is using HTTPS but your local server is likely configured to use HTTP. So you would simply need to configure TestRail to use HTTPS as well (a self-signed certificate would be sufficient). This is recommended in general.

I hope this helps!


#4

Duh, should have thought of this myself, now working with full SSL connections on both sides.

As always, one thing leads to another. Self-signed certificate works, but if not previously approved, you get the following:

Took me a minute to realize what it was doing, since the window can’t resize, you can’t see what is displayed there.


#5

Hi Fred!

Thanks for the update and great to hear that it works now! The latest version of the plugin also adds a hint/note in this case (HTTPS vs HTTP) as part of the configuration.

Regards,
Tobias


#6

Well, spoke too soon. This works for OS X users, on Windows accepting a self-signed certificate for the Testrail site in the browser doesn’t seem to affect the iframes in Jira, they continue to show up as unauthorized. I haven’t tried adding the self-signed cert as a trusted root cert in Windows since that is a major pain in the ass that has to be done on each user’s machine. I’d be interested in hearing about another workaround here; if there isn’t a better way to accomplish this, the current Jira Add-On would be kind of a problem for setups like ours (Jira Cloud + self-hosted TestRail).


#7

I was having a lot of issues with using a self-signed certificate, specifically with how to get it “installed” on each users’ browser or to get each of them to add exceptions for the certificate. It wasn’t much of an issue when it was just the actual licensed users accessing the TestRail server directly, but with the JIRA plugin that meant all of those users would now see the error in the TestRail panels in JIRA.

My eventual solution was to get our IT department to create a certificate for my server that was signed by a certificate authority. That might not be feasible for you.


#8

Hi Fred, Don,

Thanks for the update! I would also recommend using an official certificate in this case as it appear that IE doesn’t support self-signed certificates in iframes (without prior approval). Getting an official certificate usually doesn’t take a lot of work and would be a good option in this case.

Regards,
Tobias