Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

JIRA integration not working

#1

I have a user that changed their TestRail password and now their JIRA integration is not working. When hovering the mouse over a ticket number on the TestRail the ticket details are not displaying…before the user changed their TestRail password the JIRA integration was working properly.

Here is the error:
Plugin “Jira_REST” returned an error: Invalid user or password or insufficient permissions for the integration user (HTTP code 401). Please check the Jira User value in the Integration and/or User Settings has been configured correctly.

Also, seeing this with a new user that has been added. When they save the JIRA settings within TestRail they are not being saved properly. (Using Chrome)

I have the exact same setup and mine works…but I have had this configuration for a while now and have not changed since the last update to TestRail Cloud.

Any ideas?

0 Likes

#2

Hi mbowman,

The TestRail and Jira user accounts are not linked. Changing the password for TestRail does not affect the Jira integration. That said, it’s possible your user may have changed the Jira password by mistake under My Settings >> Settings.

New users will also need to assign their Jira logins under this same area as well before their TestRail accounts can push defects or view Jira references.

0 Likes

#3

Hi @vtran, thanks for the response. I understand that the accounts are not linked but it seems that before the user changed their TestRail password the JIRA integration was working properly.

TestRail cloud version: 5.6.0.3865

0 Likes

#4

Regardless of what caused the issue, I would suggest updating the password under My Settings >> Settings for that user just in case. Test that their login still works when access Jira directly, then have them enter the same login again inside TestRail.

As for your new user, what exactly did they mean by “JIRA settings within TestRail they are not being saved properly”. What is the behavior and are there any error messages?

0 Likes