Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Jira integration error?


#1

I Added the config to our testrail setup to point to our jira path which works for other tools using a specific port. When i click on “push” i get this error… any ideas?

SoapClient::SoapClient(http://jira.mycompany.com:8080/rpc/soap/jirasoapservice-v2?wsdl) [soapclient.soapclient]: failed to open stream: HTTP request failed! HTTP/1.1 503 Service Unavailable


#2

Hi Kevin,

Thanks for your message. Could you please check if Jira’s SOAP API is enabled? In some installations/versions this is not enabled by default and the error message you posted indicates this. You can check this in Jira under:

Administration > [Global Settings] General Configuration > Accept remote API calls (could also be called “SOAP API” or similar in older versions)

Is the API enabled in your Jira instance?

Thanks,
Dennis


#3

That fixed it, thanks…


#4

Hi,

I have deployed Jira 7.17 and integrate TestRails with it but when i am trying to push a defect from test rail I am getting this error message “Plugin “Jira_REST” returned an error: Invalid HTTP code (503). Please verify the address of your JIRA installation in the configuration settings and that TestRail can reach your JIRA server.”

As above suggested I tried to find out the option for ‘Accept remote API calls’ or “SOAP API” but I did’t find any option in Jira.
Although I find one option - Turn off Whtelist, i tried that but still i am getting same issue from test rail.
Although from test rail I am able to create a Jira issue.

Any help will be much appreciated, I am stuck here,

Regards,
Sanjiv


#5

Hi Sanjiv,

Can you provide a few more details about your setup? Do you use a local JIRA installation and a TestRail Cloud instance?

Cheers,
Tobias