Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

JIRA Integration error 5/18/17


#1

I’m getting the following when try to push an issue from TestRail to JIRA.

Plugin “Jira_REST” returned an error: Invalid user or password or insufficient permissions for the integration user (HTTP code 401). Please make sure to use your actual JIRA username for the integration (not your email address, for example).

I’m NOT using my email… I’m using my JIRA ID
I’m the admin in both JIRA and TestRail
I’ve edited Test Rail > My Settings > Settings to make sure I have the correct ID and PW.
I’ve gone into TestRail > Administration > Integration > Defects and set up ID and PW.


#2

Hi Bdunn,

Thank you for your post. Recently with Atlassian moving all of their customers to Atlassian ID, we have noticed a change in how the API is accessed. From what we can see and Atlassian documentation, you can either use your email address or Atlassian account username, but the password should be your Atlassian account password.

Can you please make sure you are using this password rather than you specific JIRA password?


#3

I’m a little unclear. Assume Bob, Doug and Sue all work for ACME. Are you saying make sure Bob uses Bob’s passwrod, Doug uses Doug’s password and Sue uses Sue’s password… or are Bob, Doug and Sue NOT using thier individual passwords, but instead use some ACME-level password?

FYI - I tried
a) changing my ID to my email (did not change PW) in TestRail > My Settings > Settings - same error
b) TestRail > administration > Integration changed ID to my email - same error.


#4

Hi Bdunn,

Thanks for your reply! The 401 error is provided directly from your JIRA instance and would usually just indicate either invalid credentials or insufficient permissions to access/view the JIRA project/issue. It’s also possible that the integration settings you’ve entered are incorrect. To help troubleshoot this further, can you send in a screenshot of the following to contact@gurock.com:

  • A screenshot of your Administration > Integration page (the full page please including the navigation bar above)
  • A screenshot of the error you’re receiving in specific
  • A screenshot of your profile’s My Settings > Settings tab

This will help us to troubleshoot the issue and find the cause. We look forward to your email!

Regards,
Marco


#5

I think you are right it is some kind of permission thing. We have 3 developers and a half dozen testers. All of the testers can push to JIRA but none of the developers can. I will email screen shots as per your suggestion. Thanks!


#6

Good morning team - I was able to leverage the administrator account within the integration connection of TestRail to communicate to JIRA. However, now when I push defects to JIRA - the credentials of the ADMIN are being used. I am unable to leverage the My Settings to specify that the reporter should be my individual user - rather than the Admin. Please help


#7

Hi Eric,

Thanks for your reply! You would need to be sure that the user variables are configured for the integration in order for any credentials entered under your profile > My Settings > Settings tab to be used. Anytime you have credentials entered under My Settings > Settings tab, this would always be used with the integration (and not the fallback user). Can you check to be sure the user variables are configured properly?

http://docs.gurock.com/testrail-integration/defects-plugins-variables#how_user_variables_work

Hope this helps!

Regards,
Marco