Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Jira integration - 401 when attempting push defect


#1

The error message:
Plugin “Jira_REST” returned an error: Invalid user or password or insufficient permissions for the integration user (HTTP code 401). Please make sure to use your actual JIRA username for the integration (not your email address, for example).

Testrail version 5.2.1.3472

Locally hosted testrail, jira is running in another organisation.
Logging in to jira using the same user in a browser works as expected - both viewing issues and creating new ones.
Error message appears when selecting the project available in the “push defect” window. The project name is correct from jira.
Both defects and references has been set up, and references work fine from within testrail - mousing over a reference shows correct content from Jira.
Integration is set up for a single project, not entire testrail installation, trying both user variables and user/pass directly in integration configuration.
I verified that user and pass is actually read correctly from user settings by changing to nonsense and getting an error when looking up a reference.

Unknown to me: Wether or not jira offers separate settings for users for API access. I have very limited access to the Jira installation as it belongs to another company.

Possibly related: background task may not be running. Appearantly there has been some changes to the server, but it is being looked into.

Cheers
Patrick


#2

Hi Patrick,

Thanks for your posting. This looks like a permission issue when TestRail tries to read the list of users/possible assignee for the project you select. Can you please try to disable the Assignee field on the Push Defect dialog? Please change the configuration on Administration > Integration as follows:

[push.fields]
..
assignee=off
..

Reading the list of users/assignees usually requires more privileges than some JIRA users have and it would be great if you could try this out.

Cheers,
Tobias


#3

Thank you so much! I was getting frustrated :slight_smile:
Integration is working now.

Cheers
Patrick


#4

Hi Patrick,

That’s great to hear and you are welcome :slight_smile: The Assignee field can require special permissions and I would recommend keeping this disabled for now if that works for you. Happy to help in case you have any further questions or feedback.

Cheers,
Tobias