Join 34,000+ subscribers and receive articles from our
blog about software quality, testing, QA and security.

JIRA 502 proxy after CONNECT error



I am trying to integrate JIRA with Testrail and getting this error ““Plugin “Jira_REST” returned an error: Received HTTP code 502 from proxy after CONNECT” It will be great if someone can help”"



Hello Richa,

This error actually means that you tried to integrate a TestRail Cloud account with a JIRA instance that is not available over the Internet. For the full JIRA integration TestRail needs to be able to connect to JIRA. You can still benefit from our link and new rich add-on integration even without such a connection.

You can either install TestRail on a local server as well or make JIRA available over the Internet. If your JIRA instance should already be accessible from TestRail, can you please verify the configured JIRA address and/or email us a screenshot of the integration settings?



I am able to do integration between TestRail and Jira. And when i click on the reference,when I click on the hyperlink it navigates to the Confluence screen as expected. Defects also raised is in sync between TestRail and Jira as expected.

But when I hover the mouse over the hyperlink , am gettin an error message “Plugin “Jira_REST” returned an error: Received HTTP code 502 from proxy after CONNECT”

Please let me know the solution


Hi Jobin,

As explained by Dennis above, this means that you are trying to connect from a TestRail Cloud instance to a local, self-hosted JIRA installation on your network. Can you confirm this? The Push & Lookup functionality needs a direct connection to JIRA’s API and this requires making your JIRA instance available over the Internet if you use TestRail Cloud.



We are having the same issue but I can confirm that we are NOT hosting Jira. We have saas instances for both. The integration is working generally - both TestRail and Jira have the links, but when we either hover over the link in TR or click on it, we receive the 502 error. We can pass information the other way, just not into Jira for some reason, even though it’s clearly passing enough to display in Jira that there is a test case created for an item.


Hi Michael,

Thanks for your posting. Can you send a screenshot of your Administration > Integration page (the full browser window) to our help desk at (with possible passwords removed please)? Happy to review your configuration.



Is there a workaround for those who have Jira Locally hosted?
Our set up is locally hosted (for Jira)


Hi Tony,

Yes, there’s a workaround and you would need to make your JIRA installation accessible over the Internet. That said, you can limit this to just a handful of IPs we use for TestRail Cloud and the integration and we are happy to provide this list if you could send a quick email to our help desk at



Any update to this topic? I’m currently trying to setup TestRail and JIRA (Cloud) integration. From JIRA I can see the test cases and test results, all that seems to be working correctly. But in TestRail, for example hovering over a defect, I get the same 502 error. I have the JIRA plugin setup and the integration key working, as I said I can see results from the JIRA Stories.

I also get the same error from the Defects list under the test cases, as well as if I try to Push a Defect from a test result.


Another screenshot


Hi @mikel,

Thanks for your posting. It looks like you are trying to connect to a local JIRA instance, can you confirm this? For the push/lookup functionality, TestRail needs a direct connection to JIRA to access JIRA’s API and this is only possible if TestRail can reach JIRA. If JIRA is installed on your private server behind a firewall on your own local network, then such a connection isn’t possible usually. To use the full integration, you would have the following options:

  • Make your JIRA instance available for connections over the Internet (I recommend talking to your IT team for this; we can also provide the IP addresses of our servers so you only need to approve our IPs for connections)

  • You can also install TestRail on your own local server and we can provide the necessary details for this

  • To try out the integration with JIRA, you can also create a new JIRA Cloud trial on Atlassian’s website and use this for evaluation purposes:

I hope this helps!



Incorrect, as indicated I am using JIRA Cloud Edition. This is hosted by Atlassian directly. Also as indicated, the TestRail JIRA Addon is installed and working. Its almost like your rest api is using a different method for pulling information from JIRA than it is for posting to JIRA. Its like atlassian is disallowing your CONNECT method.


Thanks for your reply. Can you please send a quick email to our help desk at with your TestRail address so we can enable debug logging? It looks like you use an incorrect JIRA address and this would help troubleshooting this issue. Can you also include a screenshot of Administration > Integration?




Actually, your post did help indirectly. For some reason, a configuration (with default example settings) somehow was added to my specific project for the defect plugin (though not for defect view or add urls), and was overriding the global integration settings. The hover references now appear to be working, as is the defect push mechanism.



That’s great to hear and thanks for the update :slight_smile: If the configuration is overridden by a project, TestRail would also indicate this with a warning/hint icon and message but good to hear that it works now!



I am logged in as an Admin account on Test Rail and i am getting 502 error while clicking on Push to defects. any help will be appreciated.


Hi vadim - did the 2nd post in this thread point you in the right direction?


no. we are using JIRA cloud and TestRail cloud.


Hi there!

With JIRA Cloud and TestRail Cloud, getting a 502 error means that the URL is not configured correctly. E.g. you might have some project overrides configured and still have the default address that you need to replace. If you are still insure, can you email us a screenshot of Administration > Integration please to and include a link to this forum posting?



So let me try to understand. I’m getting the same error and I know that we are using a non-cloud version of Jira we are hosting it locally. How do I get it setup for be able to push defects from Test Rail to Jira?