Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.

Issues related to Upgrade from 5.5 to 5.7

Hello Team ,

I have started upgrading my testrail instance from testrail 5.5 to testrail 5.7 for that we have installed PHP 7.2 a mentioned in the below document.

but after successful completing all the steps mentioned in the document we have not able to connect to testrail where we can see below error message

" XX.X.XXX.XX is currently unable to handle this request.


For further investigation we have check error.log file and found below errors

PHP Fatal error: Uncaught Error: Class ‘Services’ not found in /var/www/html/testrail/sys/boot/errors.php:86\nStack trace:\n#0 /var/www/html/testrail/app/boot/index.php(81): errors::show(‘The xml PHP ext…’, ‘TestRail needs …’)\n#1 /var/www/html/testrail/app/boot/index.php(199): prereq::xml()\n#2 /var/www/html/testrail/index.php(96): require_once(’/var/www/html/t…’)\n#3 {main}\n thrown in /var/www/html/testrail/sys/boot/errors.php on line 86

For further clarification we have installed all the required extensions like mbstring,xml,curl,json,mysql for PHP7.2

Please help us for this upgrade scenario…

I had the same issue u need to upgrate ur testrail server to PHP 7.2. our server was in house so it was pretty easy

Hi Shashank,

Thanks for your reply but my while upgrading to 5.7 I already installed PHP 7.2 but still experiencing same error and not able to load testrail index.php page.

Hi Shashank ,

Any thoughts on my above comments…

Thanks & Regards,
Kedar Pathak

Hi Kedar,

Thanks for the post. For troubleshooting installation and upgrading issues, we would generally recommend reaching out directly to the support team via email at This will allow us to gather the necessary details in private communication and assist directly. If you haven’t already, please send in an email and we’ll be happy to help.