Join 34,000+ subscribers and receive articles from our
blog about software quality, testing, QA and security.

Integration error for fields when trying to push defect


#1

Good afternoon,

I have setup the integration on Testrail to point to my JIRA instance and when trying to do a push it picks up my instance correctly as i an select my project. The summary field is populated so when i select issue type (defect) i attempt to submit but get the following error
Plugin “jira_REST” returned an error: summary: Field ‘summary’ cannot be set. It is not on the appropriate screen, or unknown

It says this for all fields types (description, assignee, priority etc)
The screens in Jira are correct as these are the main fields we have for pretty much every issue type (defect, bug, task etc)

Have you seen this before or maybe know what this could be? Everything looks correct.
My user has the correct permissions on both projects/tools

Thanks in advance
CJ


#2

Hi CJ,

Thanks for your posting. Can you try to disable the Summary field to see if this makes a difference? You can do this in the administration area on Administration > Integration as follows:

[push.fields]
summary=off

It looks like your JIRA instance doesn’t use the default Summary/Title field for issues, can you confirm this?

Cheers,
Tobias


#3

Hi Tobias,

I can confirm that our Jira does use the default summary field
Also the error occurs for Description, Priority, assignee which are all default Jira fields. It seems to be throwing this error for every field

Unfortunately if i try turning off all of the fields in Testrail that are throwing an error nothing will be populated in Jira. Its a bit of a bizarre one

Regards
CJ


#4

Hi CJ,

Can you send a screenshot of your configuration to our help desk at contact@gurock.com? (Administration > Integration, full browser window and possible passwords removed)

Cheers,
Tobias


#5

Hi,

After a long search I found the right topic :slight_smile: I have the same issue as described here for fix_version field in defect push. Was this issue resolved and/or how to resolve it?

Thanks!
Yani


Plugin Jira_Rest Returned Error HTTP Code 401
#6

Hi Yani,

Thanks for your posting. This is likely caused by a configuration change in JIRA. Can you check if the Fix Version field is available on the issue screen for the issue type you selected?

Cheers,
Tobias


#7

Hi,

Yes it is available and also mandatory.

Regards,
Yani


#8

Hi Yani,

This could also be a permission issue. Could you check the username and/or password for the integration user? For example, if JIRA does not recognize the username and/or password it might still allow some access to the issue or issue form but adding a new issue fails because the user might not have the required permissions to do so.

Cheers,
Tobias