Join 34,000+ subscribers and receive articles from our
blog about software quality, testing, QA and security.

Integrating TR with JIRA


Hello gurock community,

I’m new to TestRail and I’m trying to setup integration of TR (server version) to JIRA defects (test cloud version). I tried to follow instructions I could find via google and youtube but still the integration is not working. Is there a detailed steps or instructions on how to configure the integration of TR with JIRA?

  • What should I put as defect view URL? or should I leave this blank?
  • What should I put as defect Add URL? or should I leave this blank?
  • Should the Project integration and Administration integration have the same defect URL?
  • Plugin, I chose the JIRA cloud, but not working still. What is the right plugin?

Please help.


Have you tried the page below?


Hi BGanger,

Thanks for your suggestion.
Yes, I already done that. And in fact, I redone it again today for the second time. I added the URLs. I regenerated the integration key for TR add-on. Copied and was saved successfully.

However, from TR, if I click the ‘Push’ hyperlink, I got this error message:
Plugin “Jira_REST” returned an error: Could not resolve host:
How can I resolve the host? I googled this error but I got more confused. :frowning:

Then, if I click the ‘Add’ hyperlink, it just take me to my JIRA defect view.
I was expecting a form to create a new defect will pop-up and after saving the new defect will take me back to TR and the defect Id will be populated.

Please help. I got a presentation tomorrow to convince of our project sponsors to buy license of JIRA as our defect management tool.


Yes, even i am seeing the same errors, when i add the defect and click on the ID i got the error message

Error in the JQL Query: The character ‘/’ is a reserved JQL character. You must enclose it in a string or use the escape ‘\u002f’ instead. (line 1, character 16)

Please help me in this.


All I can do is search and post links - my company does not use JIRA integration but the basics of the Could not Resolve error is that the network can’t find the URL - so a DNS issue or mis-configured URL as noted in this thread:

Or this thread:


Hi all,

I have received further support from John Callahan of gurock. These configurations fixed the issues I encountered with defect Push and Add hyperlinks:

  1. View URL should be: https://<>/browse/%id%
  2. Add URL should be: https://<>/secure/CreateIssue!default.jspa
  3. And in the plugin field in the “address” variable, it should be: "address=https://<youraccount.atlassian.ent>/
    (Note: replace the “” as applicable)

Hope this help someone who is having the same issue.
Thank you again for all the support and recommendations.



Sorry I could not help more but glad you got the answers you needed.