Join 34,000+ subscribers and receive articles from our
blog about software quality, testing, QA and security.

Installation Issue on RHEL 7


I am trying to install on RHEL7 and I get “…is not a valid (writable) directory. Please either create the directory or adjust its permissions.” for all 3 required directories.

I have run chmod 777 on all directories and disabled SELinux (even though I will most likely need to change these back to more restrictive.)

Versions of various SW below.

Can you please help?
(note, I have also sent a mail to Jon Reynolds with screenshots as I was previously in contact him about a customer portal change)

For the install I downloaded TestRail (PHP 5.3 and later)

[mcgaleyb@myserver ~] cat /etc/redhat-release Red Hat Enterprise Linux Server release 7.4 (Maipo) [mcgaleyb@myserver ~] php -v
PHP 5.4.16 (cli) (built: Aug 5 2016 07:50:38)
Copyright © 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright © 1998-2013 Zend Technologies
with the ionCube PHP Loader (enabled) + Intrusion Protection from (unconfigured) v10.0.2, Copyright © 2002-2017, by ionCube Ltd.
mysql> SELECT version();
| version() |
| 5.6.37 |
1 row in set (0.00 sec)
[mcgaleyb@myserver ~]$ httpd -v
Server version: Apache/2.4.6 (Red Hat Enterprise Linux)
Server built: Jul 26 2017 04:45:44


I have actually just got around it by putting all directories under /var/www/html/testrail/, even though the doc recommends have folders in another location.


Don’t know if this applies to RHEL, but on Ubuntu those directories had to be owned by the user:group that httpd was running as (www-data:www-data on Ubuntu).


Yep, on RHEL 7 the user is apache and had changed to that. Plus rwx to everyone when I got stuck but still no joy. When I put them into the testrail folder and turned SELinux back on it still worked, so I will survive with the directories where they are. Would still like to know what the issues was though. :slight_smile: