Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Installation Issue - Log Directory not valid


#1

I’m in the process of installing a new instance of TestRail on a brand new VM. Apache is up and running and I’ve created a specific user for running apache/testrail. I’ve gotten to the point in the installation where it asks me to specify the attachment, reports, and log directories. I’ve tried everything I can think of, but I keep getting

“Field XXX Directory is not a valid (writable) directory. Please either create the directory or adjust its permissions.”

I’ve verified the user running httpd is my new user. I’ve even tried varies directories and permissions. I was able to get to the next step in the setup if I put /tmp as the logs directory, but as that is a horrible idea, I backed up to the previous step and did not proceed.

I’ve done my share of SA work in the past, so setting up permissions in Linux is nothing new to me, but I’ve run out of ideas on what to try. I suspect it has something to do with the way apache is setup, but there’s nothing in the log files to help. I’ve also scanned through the generated php info to see if there’s anything I can see in there. no luck.


#2

Hi Adam,

Thanks for your post! I believe we’re also working on this via email as well, but in case you didn’t get my last response, it looks like SELinux is enabled on your Linux distribution which would cause such issues (as Apache wouldn’t be able to write to the directories unless a rule was added or SELinux was disabled). Happy to continue troubleshooting this via email as well.

Regards,
Marco


#3

As soon as we disabled SELinux this fixed the issue. Thank you so much for the assistance.


#4

Hi Adam,

Thanks for the update, glad to hear you got it working now! Just let us know in case you have any further questions, and we’re happy to help!

Regards,
Marco