Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Install a php application (TestRail) on a Windows Server 2012 R2 VM

I’m attempting to install a php application (TestRail) on a Windows Server 2012 R2 VM and am experiencing some difficulty with SQL drivers. I began off by installing SQL Server 2012 from disc and attempting to introduce PHP from the Web Platform Installer, despite the fact that the download for Microsoft Drivers 3.2 for PHP v5.6 for SQL Server in IIS continued fizzling, refering to a missing reliance as the guilty party. Glancing through the log.

DownloadManager Information: 0 : Moving downloaded file 'C:\Users\Administrator\AppData\Local\Temp\2\tmpC703.tmp' to: C:\Users\Administrator\AppData\Local\Microsoft\Web Platform Installer\installers\MSODBC11\08A089BA4D1F22BB46A4553E20095A271C230D2E\msodbcsql.msi
DownloadManager Error: 0 : Signature verification failed on downloaded file. URL: http://go.microsoft.com/fwlink/?LinkID=533081. File location: C:\Users\Administrator\AppData\Local\Microsoft\Web Platform Installer\installers\MSODBC11\08A089BA4D1F22BB46A4553E20095A271C230D2E\msodbcsql.msi. File size: 3768 kb
DownloadManager Information: 0 : Product Microsoft® ODBC Driver 11 for SQL Server® done install completed
DownloadManager Information: 0 : Increasing current install to 2
DownloadManager Warning: 0 : Dependency failed for product 'Microsoft Drivers 3.2 for PHP v5.6 for SQL Server in IIS'. Skipping download.
DownloadManager Information: 0 : Product Microsoft Drivers 3.2 for PHP v5.6 for SQL Server in IIS had a dependency fail. Increasing install product to 3
DownloadManager Information: 0 : Product: MSODBC11, Install Status: InstallCompleted-Failure, Install Time: 00:00:00
DownloadManager Information: 0 : Product: SQLDriverPHP56IIS, Install Status: DependencyFailed-None, Install Time: 00:00:00

It resembled the reliance is the ODBC Driver 11, which wouldn’t install because of signature verification, so I chose to simply get everything physically. I got the 3.2 php drivers and place them in the ext index and enrolled them in php.ini and all that, yet when I tried to run the msodbcsql.msi package that was giving me issues with the Web Platform Installer I continued getting a blunder that establishment fizzled in light of the fact that it is unsupported on my working framework. Notwithstanding, the download page on Microsoft’s website records Server 2012 as perfect, and when I run sqlsrv_errors() I get:

Thanks,
Gracy Layla.

Hi gracylayla,

Thanks for the message! The error message you are receiving is likely due to a file resulting from a currpted download. You can force Web Platform Installer (WPI) to redownload the files by removing everything within C:\Users\Administrator\AppData\Local\Microsoft\Web Platform Installer\installers\