Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Github Integration not working, github returning http 410 error code


#1

I’ve been setting up the github integration, and things appear to be mostly working for me until I try to submit. When I fail a test step and click the ‘push’ link in the defect tab, an issue report dialog is opened. In this dialog, I see our list of engineers in the Assignee dropdown. I see our github labels. However, I do not see our Milestones. But what is worse is that when I click ‘Submit’, I get the following error:

I’m guessing there’s something wrong in my configuration, but I can’t spot it.
Here is what that looks like:

[connection]
address=https://api.github.com/
user=%github_user%
password=%github_pwd%

[repository]
owner=xxxxxxxx
name=xxxxxxxx

What am I missing? I entered fallback credentials of a generic QA github user


#2

Hi!

Thanks for your posting. We haven’t seen this issue before and will try to reproduce this. Could you check your repository settings again and if this might be a temporary issue?

Cheers,
Tobias


#3

I believe this was because I had the wrong data here:

[repository]
owner=xxxxxxxx

I had listed the user who I thought was the “owner” (creator) of the repository, but it appears that what is wanted here is the organization to which the repository belongs. Changing that has resolved the issue.


#4

Yes, this expects the organization/group of the repository. Great to hear that it works now!

Cheers,
Tobias


#5

I tried to use the API along with the username from the UI, it failed to authenticate. Getting error from UI.

this was working for us earlier. but we recently changed the protocol to HTTPS instead of HTTP.
Any changes which we need to do for this when we change to HTTPs from HTTP?

with regards