Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Generating PDF via report is not working

We tried to set our weekly reports with PDF attachments and it seems like it is not working at all, Have tried to send HTML and that is working fine but since our IT has blocked some unsafe files(such as javascripts) over emails we don’t want to use the HTML option.
We then tried to download the manual report by pressing the download button and got this error if we select Download PDF.

Can anyone please help?

There are a number of potential possibilities here:

For us - we had TR installed on the client machine to a folder other than the ‘standard’ inetpub/wwwroot folder.

It can be related to permissions, install folder, or other dependencies that may need to be updated.

Hello Nino,

Thank you for the post! As Bganger mentioned, there are multiple reasons why you might receive this error message. I recommend reviewing the discussion in the thread posted above as this lists many of the solutions for this error. If you are still unsure or are experiencing issues after reviewing these solutions, please reach out to the TestRail support team directly at contact@gurock.com with the full error report and we will be happy to help.

Regards,
John