Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Formatting don't work with custom fields step?


#1

Hello,

i add a custom field Steps to my test cases, but the formatting doesn’t work.

I want to use someting like the Advanced lists

For example

  1. Open *.txt file
    • lanch the open file dialog
    • select file format (*.txt)
    • Open *.txt file

the expectet output should be someting like that.

  1. Open .txt file
    [list=
    ]
    []anch the open file dialog[/]
    [/list]
    [list=]
    [
    ]select file format (.txt)[/]
    [/list]
    [list=]
    [
    ]Open .txt file[/]
    [/list]

In the Step Results the formatting works correct, but in the Print Dialog and the TestCase itself the formatting doesn’t work.


#2

Hello,

you need to select the Markdown text format for this custom field. Please go Administration > Custom Fields, select the custom field and change the text format to Markdown on the Project Assignments tab. By default, the text format for the Steps and Step Results fields is set to Plain Text (this will change with the upcoming version).

Regards,
Tobias


#3

OK now it works :slight_smile: , thankyou for your quick help :D.


#4

I realize this is a very old topic but I have a question about this functionality. I go to to add a Custom Field. When I click the “Type” dropdown box, I do not see a “Markdown” option. Only type “Text.” You mention above that Markdown is planned to be supported by default - may I assume that has been implemented now, some 5 years later? :grinning: If so you may want to consider changing this page to reflect this. The description in the table for type Text says “You can specify if a Text field should support Markdown formatting or just plain text.”


#5

Ahh, now I see where I can make that selection! The dropdown selector between Plain Text and Markdown doesn’t show up until I assign the new custom field to a project. :blush:


#6

Hi Jeff,

Great to hear that you found the option :smile:

Cheers,
Tobias