Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Field Default Access is a required field - when trying to modify project access for a user

Hello -

We have an issue that seems to only effect one project in our instance. If I open administration > projects - select the project and click on the ‘access’ tab. From there is I scroll down to the bottom and click save (with or without making any user ‘project access’ changes) I get the following error -
“Field Default Access is a required field”. All of our other projects seem to be fine from a recent spot check, but this one project is not playing nice.

Any ideas on how to fix this issue? It’s blocking multiple test teams. Thanks!

Anyone? Our instance is crippled at the moment until we can fix this issue. I checked the logs and I’m seeing that this may be related to Jira integration. See logs below. I’ve confirmed the correct password is set and this worked up until Friday of last week.

[Jira_RESTException] Invalid user or password or insufficient permissions for the integration user (HTTP code 403). Please make sure to use your actual JIRA username for the integration (not your email address, for example).
---
Details: <missing>
File: D:\inetpub\wwwroot\testrail\app\plugins\defects\Jira_REST.php
Line: 1868
Status Code: 500
Host: testrail
Uri: /index.php?/references/ajax_lookup (POST)
---
Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.70 Safari/537.36
PHP: 5.6.9
Server: Windows NT 6.2 build 9200 (Windows Server 2012 R2 Standard Edition) i586
---
project_id: 276
reference_id: PAY-103405
_token: hECYPoIMbCMvWS9X5AcW
_version: 5.4.1.3669
---
Trace:
at Jira_REST_api->_throw_error (Jira_REST.php:1503)
at Jira_REST_api->_send_request (Jira_REST.php:1444)
at Jira_REST_api->_send_command (Jira_REST.php:1438)
at Jira_REST_api->get_issue (Jira_REST.php:805)
at Jira_REST_defect_plugin->lookup (references.php:62)
at References_controller->ajax_lookup (controller.php:257)
at Controller->_invoke_web_call (controller.php:168)
at Controller->_invoke_web (controller.php:120)
at Controller->_invoke (gizmo.php:107)
at require_once (index.php:106)

Thanks!

I posted a response the day of the original post - not sure where it went but I must not have saved it.

What is the value in the field below - for the project in question?
image

By default there should be a value of Global Default. If that is there - then it would point to a JIRA issue.

Is this for the Could version of TR? They had an issue with integration I think with the last patch and put in a fix in the last 24 hours.

If it is still an issue and people can’t work - go to the main support page and open a ticket. For production issues where people can’t work - that should be the first go to place to go…

The default value is “global role”, so that looks right. It’s always worked before. This is for our on-prem instance of Testrail. Upon further inspection it now appears that every project in our instance is impacted by this. As I posted in the logs above, it appears to be an issue with Jira integration plugin. I’ll open a support ticket as suggested. Thanks

Hi @dzarelli,

Thanks for the post! This error is likely related to the PHP setting for max_input_vars and a high number of users in your TestRail installation. The default value for this is 1000, and we would recommend increasing this to a higher number such as 10000 within your php.ini file.

Once you make the change, please make sure to restart your web server.

Hope this helps,
Jon