Subscribe Join 180,000+ subscribers and receive articles from our blog about software quality, testing, QA and security. Subscribe

Export/Import XML

So, it looks like I’ve run into a bit of a problem with the xml import function.
I created a test suite in Testrail that consists of multiple sections and test cases.
I wanted to export that to xml in order to edit and share the test suite.
The problem I’ve run into is that I can’t import (update existing cases) the exact same xml file I just exported.
Testrail just throws the following error.

“Too few arguments to function Case_model::_update_full(), 11 passed in /var/www/testrail/6.3.0.1120/app/models/case.php on line 1301 and exactly 12 expected”

Note: I didn’t change anything on the exported file, or even open it. I immediately imported it.
Any Ideas?

2 Likes

Noone has any ideas?

Welcome to the forums…

I am somewhat confused… from my reading/understanding you created a new Test Suite (that some how has sections/test cases?) and then you are trying to import them… where?

What I was thinking when I read it the first time was that you exported sections/cases from a suite, created a new suite and tried to import in to the new suite.

My WaG is that there is a difference between the 2 suites and cases that results in the import expecting 12 arguments and the XML only has 11.

Why not share the original Suite? What are you trying to solve?

I was trying to figure out why the xml import function wasn’t working. That’s why I exported my test suite and tried to re-import it. That’s when I discovered that I couldn’t import a suite I had just exported for some reason.

I run into this problem, too…

1 Like

I am making sure that the following is true for both cases:

  1. XML file was created of the suite and
  2. You created a new suite and choose the option to Add new test cases:
    image

I only have 6.2 to test with but it works fine with an empty Suite and XML file (exported a test suite from our Production and imported into a brand new empty Suite in our Test environment without issue. My works Prod/Test environment are on the same version - we run the server version not the Cloud.

I think it only happen in 6.3, which I’m using now. Recently, I often use this feature to edit my test case. But in one day, the problem just happen, and the file that can import into testrail successfully before cannot import anymore.

and I didn’t see the option to switch to the previous version like 6.2 …

You can’t go backward since any update could include db changes.

That makes sense. I don’t remember seeing the problem prior to the latest update.

Hi Jeff,

Could you please send an email to contact@gurock.com with as much detail as possible regarding the issue as well as your account details.

Thanks,
Shanu

will do, no problem…

1 Like

I faced the same problem…
image

Sometimes I use XML import/export to bulk editing of test cases, for example, when I need to fix a word everywhere. I export the test suite, do some changes in XML then import it into the same test suite using the “Update existing test cases” option. This had worked well until the update to 6.3.

Now I get the error on attempt to import XML even if I try to import the exported XML file without any changes. TestRail v6.3.1.1006 is used.

Yes, that’s exactly what I was seeing.

@jhuntamer

Hi Jeff,

Are you still facing the same issue ? If yes, do you have an active ticket in place ? I can definitely reach out to our support team to get an update.

Thanks,
Shanu

@emorozova

Hi Elena,

Could you also send an email to contact@gurock.com with as much detail as possible regarding the issue as well as your account details.

Thanks,
Shanu

@shanu.mandot
Hi Shanu,
as far as I know, my colleague has already contacted support by e-mail.

I might add that I’ve tried to export and then import the whole test suite (~1 hundred sections, ~8 hundred of test cases, level nesting depth not greater than 5), and the issue is exactly being repeated.

The same issue is observed on the latest version of TestRail (v6.4.0.1284), the error message is the same as in the previous version, except for the version number in the path:

Too few arguments to function Case_model::_update_full(), 11 passed in /var/www/testrail/6.4.0.1284/app/models/case.php on line 1301 and exactly 12 expected

1 Like