Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Export CSV: Steps missing

Hi there,
When I export in CSV, the column Steps is empty.
I do have Expected Results though.
I can find it on the XML Export.
Could you help me?
I use TestRail v5.7.1.4026 on SAAS.
Regards,
Timothée

Timothee,

From your question, I am only guessing on what you were trying to export, I’m guessing you were trying to export a TestCase (??), and you have multiple steps as part of the Test Case… When you select export to CSV, did you make sure you selected the two fields:

  • Steps (Expected Results)
  • Steps (Steps)

This is the excel file with the two selections:

Hope that helps…

Hi Timothée,

Thanks for the post! As mlampey pointed out above, you’ll need to ensure you’re checking the correct boxes when performing the export so all the correct fields are present in the spreadsheet. Depending on the template(s) you are using for your test cases, there may be different fields present when performing the export, which can get confusing. You may see two “Steps” options, as well as a “Steps (Step)” option, and you may want to do an export with all three checked to determine which you’ll need.

The two “Steps” fields are for the different templates used. If you’ve got some tests using the Test Case (Steps) template (where you can specify each test step in a separate field), and others using the the Test Case (Text) template (where you have one large text field to specify all test instructions), each of those field values will export into a separate column under the “Steps” heading.

One thing to note, with the Test Case (steps) template exports, the general “Steps” column will export the individual test steps as well as the expected results into one field, while choosing the “Steps (Step)” and “Steps (Expected Result)” options will separate those into different columns. When using the Test Case (Text) template the Steps and Expected Results columns will be separate, and there isn’t an export option to include them both in the same field.

Hi mlampey & Jacob,
Thanks for your time.
I checked all the boxes. I have the column in the CSV but they are empty.
Look at my attachments.


KR,
Timothée

I can see some values in my field: